dev-python/colout: Babel now supports py3
authorMichał Górny <mgorny@gentoo.org>
Sat, 22 Apr 2017 16:19:57 +0000 (18:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 22 Apr 2017 16:41:04 +0000 (18:41 +0200)
dev-python/colout/colout-0.1.ebuild

index bea85ddb7701d72866874debc60604772fb1e204..b88519a236603308f76a9401bf29598f7d11613b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -17,7 +17,7 @@ IUSE=""
 
 RDEPEND="
        dev-python/pygments[${PYTHON_USEDEP}]
-       dev-python/Babel[$(python_gen_usedep 'python2*')]
+       dev-python/Babel[${PYTHON_USEDEP}]
 "
 
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -27,10 +27,3 @@ src_prepare() {
        sed -e 's:BSD licensed:GPL-3 licensed:' -i README || die
        distutils-r1_src_prepare
 }
-
-pkg_postinst() {
-       if [[ "${PYTHON_TARGETS}" == *python3* ]]; then
-               ewarn "Though ${PN} supports Python 3, Babel does not, thus it's number parsing feature won't be used."
-               ewarn "If you need it, use Python 2."
-       fi
-}