sys-cluster/ceph-14.2.9-r1: Remove patch to change boost sonames
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 23 Apr 2020 20:41:00 +0000 (13:41 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 23 Apr 2020 20:44:22 +0000 (13:44 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
sys-cluster/ceph/ceph-14.2.9-r1.ebuild

index fc084cb849759892f6df93679baed99cdff4cd86..795abd75b7c04d1d923674cc8ac54148b119fb6f 100644 (file)
@@ -163,7 +163,7 @@ PATCHES=(
        "${FILESDIR}/ceph-14.2.5-no-virtualenvs.patch"
        "${FILESDIR}/ceph-13.2.2-dont-install-sysvinit-script.patch"
        "${FILESDIR}/ceph-14.2.0-dpdk-cflags.patch"
-       "${FILESDIR}/ceph-14.2.0-link-crc32-Wstatically.patch"
+       "${FILESDIR}/ceph-14.2.0-link-crc32-statically.patch"
        "${FILESDIR}/ceph-14.2.0-cython-0.29.patch"
        "${FILESDIR}/ceph-14.2.3-dpdk-compile-fix-1.patch"
        "${FILESDIR}/ceph-14.2.4-python-executable.patch"
@@ -197,12 +197,10 @@ src_prepare() {
        cmake-utils_src_prepare
 
        if use system-boost; then
-               eapply "${FILESDIR}/ceph-14.2.8-boost-sonames.patch"
-
                find "${S}" -name '*.cmake' -or -name 'CMakeLists.txt' -print0 \
                        | xargs --null sed \
-                       -e 's|Boost::|Boost_|g' \
-                       -e 's|Boost_boost|boost_system|g' -i || die
+                       -e 's|Boost::|boost_|g' \
+                       -e 's|boost_boost|boost_system|g' -i || die
        fi
 
        sed -i -r "s:DESTINATION .+\\):DESTINATION $(get_bashcompdir)\\):" \