gnustep-apps/preview: Port to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Wed, 3 Jan 2018 18:38:27 +0000 (19:38 +0100)
committerDavid Seifert <soap@gentoo.org>
Wed, 3 Jan 2018 18:38:27 +0000 (19:38 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

gnustep-apps/preview/preview-0.9.ebuild

index 1f5d11774224a8cd490daeaecca32984c056da91..f7bac95e785dc74813caa44de5c612b899d33f52 100644 (file)
@@ -1,21 +1,27 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=3
-inherit gnustep-2
+EAPI=6
 
-S=${WORKDIR}/${PN/p/P}
+inherit gnustep-2
 
 DESCRIPTION="Simple image viewer"
 HOMEPAGE="http://www.sonappart.net/softwares/preview/"
 SRC_URI="http://www.sonappart.net/softwares/preview/download/${P/p/P}.tar.gz"
+
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
 IUSE=""
 
-src_prepare() {
-       sed -e 's/sel_eq(/sel_isEqual(/' -i Document.m || die "sed failed"
+S=${WORKDIR}/${PN/p/P}
+
+PATCHES=(
        # Fix compilation, patch from debian
-       epatch "${FILESDIR}"/${PN}-0.8.5-compilation-errors.patch
+       "${FILESDIR}"/${PN}-0.8.5-compilation-errors.patch
+)
+
+src_prepare() {
+       default
+       sed -e 's/sel_eq(/sel_isEqual(/' -i Document.m || die
 }