dev-python/pysol_cards: 0.8.7 version bump, python3_8
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 30 Dec 2019 23:38:49 +0000 (00:38 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 30 Dec 2019 23:38:49 +0000 (00:38 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/pysol_cards/Manifest
dev-python/pysol_cards/pysol_cards-0.8.7.ebuild [new file with mode: 0644]

index 33d5ffc42361077029a2050529da9d46f430bb75..abb0e58c25ad59654b9f3a2d0bc3ab2560005e7d 100644 (file)
@@ -1 +1,2 @@
 DIST pysol_cards-0.8.6.tar.gz 17674 BLAKE2B b46c2a39b04e339e7e9a548cfb4e7f06e49969bbdfd9dc35f2662973bae60e52b576bc2174c86fa9ed33d69703257690d9d024b9ca474a4bbd028c5ec958b5e2 SHA512 da446e0deed0f8ff60a4da82a8bce5d1884d35e52ee887a6b07b82fa6fbf04b07d1758b8039532db5163f89395239295f6eec1f278cd183b22e41f1e90416040
+DIST pysol_cards-0.8.7.tar.gz 19469 BLAKE2B 94e438a9b0bb94c5657ddda92f45cc7b4f950ecfca43128ff6ef360c5066763ffe7d5ad86272aad343f5a42f66b9d71c412ba007cd0b7f39e6adef176bc2d5dc SHA512 835e03e110ff99e8eaa226b1d4f93e1ffe529b9311ec3e45f9884981f9956b0e5092f264426c80e94bea9f1ca57803f10d47a1fa2b587dcd04baf6bac4a015c0
diff --git a/dev-python/pysol_cards/pysol_cards-0.8.7.ebuild b/dev-python/pysol_cards/pysol_cards-0.8.7.ebuild
new file mode 100644 (file)
index 0000000..d64c0f2
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Deal PySol FreeCell cards"
+HOMEPAGE="https://pypi.org/project/pysol-cards/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       dev-python/pbr[${PYTHON_USEDEP}]
+       dev-python/random2[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+"