dev-php/pecl-stomp: Fix build error finding OpenSSL
authorBrian Evans <grknight@gentoo.org>
Wed, 19 Jun 2019 17:19:47 +0000 (13:19 -0400)
committerBrian Evans <grknight@gentoo.org>
Wed, 19 Jun 2019 17:19:47 +0000 (13:19 -0400)
Closes: https://bugs.gentoo.org/688360
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Brian Evans <grknight@gentoo.org>
dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild

index d808c2c1b91795481d787fc6fc9581a403e1ae3e..99522e6709c5e568eb1c7824ab9ddbd6f3a6727c 100644 (file)
@@ -27,6 +27,8 @@ DEPEND="${DEPEND}
 RDEPEND="${DEPEND}
        php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
 
+DEPEND="virtual/pkgconfig ${DEPEND}"
+
 src_prepare() {
        if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                php-ext-source-r3_src_prepare
@@ -39,7 +41,7 @@ src_configure() {
        if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
                local PHP_EXT_ECONF_ARGS=(
                        --enable-stomp
-                       --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
+                       --with-openssl-dir=$(usex ssl yes no)
                )
                php-ext-source-r3_src_configure
        fi