sys-devel/gettext: Fixed parallel install issue
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 10 May 2019 18:40:17 +0000 (20:40 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 10 May 2019 18:40:52 +0000 (20:40 +0200)
Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Closes: https://bugs.gentoo.org/685530
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-devel/gettext/files/gettext-0.20-avoid_eautomake.patch [new file with mode: 0644]
sys-devel/gettext/files/gettext-0.20-parallel_install.patch [new file with mode: 0644]
sys-devel/gettext/gettext-0.20.ebuild

diff --git a/sys-devel/gettext/files/gettext-0.20-avoid_eautomake.patch b/sys-devel/gettext/files/gettext-0.20-avoid_eautomake.patch
new file mode 100644 (file)
index 0000000..16592c8
--- /dev/null
@@ -0,0 +1,22 @@
+--- gettext-0.20/gettext-tools/src/Makefile.in
++++ gettext-0.20/gettext-tools/src/Makefile.in
+@@ -3952,9 +3952,16 @@
+ # How to get the include files of libtextstyle.
+ textstyle.h textstyle/stdbool.h textstyle/version.h textstyle/woe32dll.h:
+-      here=`pwd`; \
+-      cd ../../libtextstyle/lib && \
+-        $(MAKE) install-nobase_includeHEADERS install-nobase_nodist_includeHEADERS includedir="$$here"
++      cd "$(abs_top_builddir)/../libtextstyle/lib" && $(MAKE) $@
++      if test -f "$(abs_top_builddir)/../libtextstyle/lib/$@"; then \
++              file="$(abs_top_builddir)/../libtextstyle/lib/$@"; \
++      else \
++              file="$(abs_top_srcdir)/../libtextstyle/lib/$@"; \
++      fi; \
++      target_dir="$(abs_builddir)/$@"; \
++      target_dir="$${target_dir%/*}"; \
++      $(MKDIR_P) "$${target_dir}"; \
++      $(INSTALL_HEADER) "$$file" $@
+ # No need to install libgettextsrc.a, except on AIX.
+ install-exec-hook: install-exec-clean
diff --git a/sys-devel/gettext/files/gettext-0.20-parallel_install.patch b/sys-devel/gettext/files/gettext-0.20-parallel_install.patch
new file mode 100644 (file)
index 0000000..e47beaf
--- /dev/null
@@ -0,0 +1,37 @@
+From 829660df1583c6c3ee1d90291dd910f08e3b777e Mon Sep 17 00:00:00 2001
+From: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
+Date: Fri, 10 May 2019 20:08:25 +0200
+Subject: [PATCH] Fix parallel install issue
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ gettext-tools/src/Makefile.am | 13 ++++++++++---
+ 1 file changed, 10 insertions(+), 3 deletions(-)
+
+diff --git a/gettext-tools/src/Makefile.am b/gettext-tools/src/Makefile.am
+index 09a3c153d..1ee49cdca 100644
+--- a/gettext-tools/src/Makefile.am
++++ b/gettext-tools/src/Makefile.am
+@@ -252,9 +252,16 @@ cldr_plurals_LDADD = libgettextsrc.la $(LDADD)
+ # How to get the include files of libtextstyle.
+ textstyle.h textstyle/stdbool.h textstyle/version.h textstyle/woe32dll.h:
+-      here=`pwd`; \
+-      cd ../../libtextstyle/lib && \
+-        $(MAKE) install-nobase_includeHEADERS install-nobase_nodist_includeHEADERS includedir="$$here"
++      cd "$(abs_top_builddir)/../libtextstyle/lib" && $(MAKE) $@
++      if test -f "$(abs_top_builddir)/../libtextstyle/lib/$@"; then \
++              file="$(abs_top_builddir)/../libtextstyle/lib/$@"; \
++      else \
++              file="$(abs_top_srcdir)/../libtextstyle/lib/$@"; \
++      fi; \
++      target_dir="$(abs_builddir)/$@"; \
++      target_dir="$${target_dir%/*}"; \
++      $(MKDIR_P) "$${target_dir}"; \
++      $(INSTALL_HEADER) "$$file" $@
+ BUILT_SOURCES    += textstyle.h textstyle/stdbool.h textstyle/version.h textstyle/woe32dll.h
+ MOSTLYCLEANFILES += textstyle.h textstyle/stdbool.h textstyle/version.h textstyle/woe32dll.h
+-- 
+2.21.0
+
index e4877a91a2ab1a5f7f6516689056616f777faa54..8f4c83d53216c558501a9222a2a3dfd23a5fc66e 100644 (file)
@@ -51,6 +51,8 @@ MULTILIB_WRAPPED_HEADERS=(
 
 PATCHES=(
        "${FILESDIR}"/${PN}-0.19.7-disable-libintl.patch #564168
+       "${FILESDIR}"/${PN}-0.20-parallel_install.patch #685530
+       "${FILESDIR}"/${PN}-0.20-avoid_eautomake.patch
 )
 
 pkg_setup() {