dev-db/pgadmin4: Bump to 4.8
authorAaron W. Swenson <titanofold@gentoo.org>
Thu, 6 Jun 2019 10:01:51 +0000 (06:01 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Thu, 6 Jun 2019 10:01:58 +0000 (06:01 -0400)
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
dev-db/pgadmin4/Manifest
dev-db/pgadmin4/pgadmin4-4.8.ebuild [new file with mode: 0644]

index 09317295a69d30ffabf6151a76cae4b71d2edbeb..71bcca5efc9e3426d7fb3833a0748ac4397595dc 100644 (file)
@@ -2,3 +2,4 @@ DIST pgadmin4-3.0.tar.gz 28915010 BLAKE2B 7e6dccd91f082f7b5514f5d3abdf4653a9961b
 DIST pgadmin4-4.2.tar.gz 32382384 BLAKE2B c96806302e7c298e9fcdee3ada8fc519431eb3de778c55445de648e2867dc32168c5ad38209da63ac2d181612b2edfdd532f11ccd6020ab187c6fe23ef6272a6 SHA512 d3d242904c65f0af871890954c24005b4849b88599cde9a7cb82e077ff5db5a8c5f015c4af0b135d68f02daad42492af71373831c2212a36672af8d7621c3b2a
 DIST pgadmin4-4.3.tar.gz 22480328 BLAKE2B 4a7527b59d3b9f3cbfa63003c09ffe2c826dd965e906c46939324182ffa5c9c0e0258fd56be1480555ed4cbc1b42231727d632ccc7c3339982412654100db38e SHA512 db072bab1dcd0a18b9c423b95847c7873b9f458168ebaaf6473a9de5b44b3134e39f5b84aeba0a6ada42b1e867e359e44bda84bf55377cb0abc169c7455852b6
 DIST pgadmin4-4.5.tar.gz 22420769 BLAKE2B ae16e34c4cfce0ae78f06321ea1fc34aac0e081df4c0d5906fc4da0c82abb67e374477b8f9a9266d003579eb8887541e4224465ce6eccd86589129e1b3efff24 SHA512 835434612ac2a7ff89fab4c4bed89644e43506491ce12d2b74ffdbc25b33f2ac9ae566c95e886d4b4f8bca6499c40be5f0d776b18bfdcebd44d7ffe3b89deb5f
+DIST pgadmin4-4.8.tar.gz 22780924 BLAKE2B 7b64ef8ac3782e9c8207d5938f3638d67ddf5c86ca520afbfb296a824b39411362ca6e9d8b03920e35cca38d1303efe81750e5bfc849cfb363f370da3d25ac44 SHA512 68b35c1091435fbeb39e67c7f93038fcba95cd5ae7098434b5d3afee10595f875ef9fd997934f2bbd93c914bcd5c3c71bd43f032f788e55c5795f5ad63b57cd7
diff --git a/dev-db/pgadmin4/pgadmin4-4.8.ebuild b/dev-db/pgadmin4/pgadmin4-4.8.ebuild
new file mode 100644 (file)
index 0000000..31cf045
--- /dev/null
@@ -0,0 +1,124 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 qmake-utils
+
+DESCRIPTION="GUI administration and development platform for PostgreSQL"
+HOMEPAGE="https://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin/${PN}/v${PV}/source/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc"
+
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+       dev-qt/qtnetwork:5
+       dev-qt/qtwidgets:5
+"
+
+DEPEND="${COMMON_DEPEND}
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       >=app-text/htmlmin-0.1.12[${PYTHON_USEDEP}]
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       >=dev-python/beautifulsoup-4.4.1[${PYTHON_USEDEP}]
+       >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+       >=dev-python/click-6.6[${PYTHON_USEDEP}]
+       >=dev-python/cryptography-2.2.2-r1[${PYTHON_USEDEP}]
+       >=dev-python/extras-1.0.0[${PYTHON_USEDEP}]
+       >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-0.12.4[${PYTHON_USEDEP}]
+       >=dev-python/flask-babel-0.11.1[${PYTHON_USEDEP}]
+       >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
+       >=dev-python/flask-gravatar-0.5.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-htmlmin-1.3.2[${PYTHON_USEDEP}]
+       >=dev-python/flask-login-0.3.2[${PYTHON_USEDEP}]
+       >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
+       >=dev-python/flask-migrate-2.1.1[${PYTHON_USEDEP}]
+       >=dev-python/flask-paranoid-0.2.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-security-3.0.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-sqlalchemy-2.3.2[${PYTHON_USEDEP}]
+       >=dev-python/flask-wtf-0.14.2[${PYTHON_USEDEP}]
+       >=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}]
+       >=dev-python/itsdangerous-0.24[${PYTHON_USEDEP}]
+       >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
+       >=dev-python/linecache2-1.0.0[${PYTHON_USEDEP}]
+       >=dev-python/markupsafe-0.23[${PYTHON_USEDEP}]
+       >=dev-python/mimeparse-1.6.0[${PYTHON_USEDEP}]
+       >=dev-python/passlib-1.7.1[${PYTHON_USEDEP}]
+       >=dev-python/pbr-3.1.1[${PYTHON_USEDEP}]
+       >=dev-python/psutil-5.4.7[${PYTHON_USEDEP}]
+       >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+       >=dev-python/pyrsistent-0.14.2[${PYTHON_USEDEP}]
+       >=dev-python/python-dateutil-2.7.1[${PYTHON_USEDEP}]
+       >=dev-python/python-sqlparse-0.2.4[${PYTHON_USEDEP}]
+       >=dev-python/pytz-2018.3[${PYTHON_USEDEP}]
+       >=dev-python/simplejson-3.13.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+       >=dev-python/speaklater-1.3[${PYTHON_USEDEP}]
+       >=dev-python/sqlalchemy-1.2.5[${PYTHON_USEDEP}]
+       >=dev-python/sshtunnel-0.1.3[${PYTHON_USEDEP}]
+       >=dev-python/werkzeug-0.9.6[${PYTHON_USEDEP}]
+       >=dev-python/wtforms-2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}"/${P}/runtime
+
+src_prepare() {
+       cd "${WORKDIR}"/${P} || die
+       default
+}
+
+src_configure() {
+       eqmake5
+}
+
+src_compile() {
+       default
+       if use doc; then
+               cd "${WORKDIR}"/${P} || die
+               emake docs
+       fi
+}
+
+src_install() {
+       dobin pgAdmin4
+
+       cd "${WORKDIR}"/${P} || die
+
+       local APP_DIR=/usr/share/${PN}/web
+       insinto "${APP_DIR}"
+       doins -r web/*
+       cat > "${D}${APP_DIR}"/config_local.py <<-EOF
+               SERVER_MODE = False
+               UPGRADE_CHECK_ENABLED = False
+       EOF
+       python_optimize "${D}${APP_DIR}"
+
+       local CONFIG_DIR="/etc/xdg/pgadmin"
+       dodir "${CONFIG_DIR}"
+       cat > "${D}${CONFIG_DIR}"/pgadmin4.conf <<-EOF
+               [General]
+               ApplicationPath=${APP_DIR}
+               PythonPath=$(python_get_sitedir)
+       EOF
+
+       if use doc; then
+               rm -r docs/en_US/_build/html/_sources || die
+               insinto /usr/share/${PN}/docs/en_US/_build
+               doins -r docs/en_US/_build/html
+       fi
+}