gnome-base/gnome-control-center: Fix compilation with USE=-wayland without gtk+[wayland]
authorMart Raudsepp <leio@gentoo.org>
Sat, 15 Jul 2017 04:12:49 +0000 (07:12 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 15 Jul 2017 04:12:49 +0000 (07:12 +0300)
Gentoo-bug: 624960
Package-Manager: Portage-2.3.5, Repoman-2.3.2

gnome-base/gnome-control-center/files/3.24.2-fix-without-gdkwayland.patch [new file with mode: 0644]
gnome-base/gnome-control-center/gnome-control-center-3.24.2.ebuild

diff --git a/gnome-base/gnome-control-center/files/3.24.2-fix-without-gdkwayland.patch b/gnome-base/gnome-control-center/files/3.24.2-fix-without-gdkwayland.patch
new file mode 100644 (file)
index 0000000..0d41cca
--- /dev/null
@@ -0,0 +1,47 @@
+From 13437b364fe56ffaaa421b8396ba761a2e0cc13d Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 15 Jul 2017 06:22:16 +0300
+Subject: [PATCH] common: Add missing GDK_WINDOWING_WAYLAND guards for
+ gsd_udev_device_manager_lookup_device
+
+commit 8f9259ac06db added a gdkwayland specific lookup_device implementation, guard it
+with compile-time GDK_WINDOWING_WAYLAND as other places are.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=780544
+---
+ panels/common/gsd-device-manager-udev.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/panels/common/gsd-device-manager-udev.c b/panels/common/gsd-device-manager-udev.c
+index fdda02a..5dc4447 100644
+--- a/panels/common/gsd-device-manager-udev.c
++++ b/panels/common/gsd-device-manager-udev.c
+@@ -24,7 +24,9 @@
+ #include <string.h>
+ #include <gudev/gudev.h>
++#ifdef GDK_WINDOWING_WAYLAND
+ #include <gdk/gdkwayland.h>
++#endif
+ #include "gsd-device-manager-udev.h"
+ struct _GsdUdevDeviceManager
+@@ -227,6 +229,7 @@ static GsdDevice *
+ gsd_udev_device_manager_lookup_device (GsdDeviceManager *manager,
+                                      GdkDevice        *gdk_device)
+ {
++#ifdef GDK_WINDOWING_WAYLAND
+       const gchar *node_path;
+       GHashTableIter iter;
+       GsdDevice *device;
+@@ -243,6 +246,7 @@ gsd_udev_device_manager_lookup_device (GsdDeviceManager *manager,
+                       return device;
+               }
+       }
++#endif
+       return NULL;
+ }
+-- 
+2.10.2
+
index ac0ba455299086272b6fa9f6d45d6720e252c2a2..763ab0eb1742f1c8ff338683c833c7eb0ce895c7 100644 (file)
@@ -138,6 +138,8 @@ PATCHES=(
        "${FILESDIR}"/${PV}-optional-cups.patch
        # Fix some absolute paths to be appropriate for Gentoo
        "${FILESDIR}"/${PV}-gentoo-paths.patch
+       # https://bugzilla.gnome.org/show_bug.cgi?id=780544
+       "${FILESDIR}"/${PV}-fix-without-gdkwayland.patch
 )
 
 src_configure() {