dev-vcs/git-sh: new EAPI=6 revision.
authorMichael Orlitzky <mjo@gentoo.org>
Fri, 5 May 2017 18:17:58 +0000 (14:17 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 5 May 2017 18:18:48 +0000 (14:18 -0400)
A more-or-less standard revision bump. I've removed the postinst
message about bash-completion, because the flag is no longer present
in dev-vcs/git.

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-vcs/git-sh/git-sh-1.3-r1.ebuild [new file with mode: 0644]
dev-vcs/git-sh/git-sh-1.3.ebuild [deleted file]

diff --git a/dev-vcs/git-sh/git-sh-1.3-r1.ebuild b/dev-vcs/git-sh/git-sh-1.3-r1.ebuild
new file mode 100644 (file)
index 0000000..54b92f1
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A customized bash environment suitable for git work"
+HOMEPAGE="https://github.com/rtomayko/git-sh"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+       default
+       sed -e 's/git-completion\.bash //' \
+               -e 's:/local::' \
+               -i Makefile \
+               || die "sed failed"
+}
diff --git a/dev-vcs/git-sh/git-sh-1.3.ebuild b/dev-vcs/git-sh/git-sh-1.3.ebuild
deleted file mode 100644 (file)
index 39b2f16..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit vcs-snapshot
-
-DESCRIPTION="A customized bash environment suitable for git work"
-HOMEPAGE="https://github.com/rtomayko/git-sh"
-SRC_URI="https://github.com/rtomayko/git-sh/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="dev-vcs/git"
-
-src_prepare() {
-       sed \
-               -e 's/git-completion\.bash //' \
-               -e 's:/local::' -i Makefile || die "sed failed"
-}
-
-pkg_postinst() {
-       echo
-       einfo "For bash completion in git commands emerge dev-vcs/git"
-       einfo "with bash-completion USE flag."
-       echo
-}