per bug 204468, remove old check from repoman (all ebuilds in gentoo-x86 are migrated).
authorAlec Warner <antarus@gentoo.org>
Sat, 5 Jan 2008 20:31:31 +0000 (20:31 -0000)
committerAlec Warner <antarus@gentoo.org>
Sat, 5 Jan 2008 20:31:31 +0000 (20:31 -0000)
svn path=/main/trunk/; revision=9144

bin/repoman

index c4453f9924c3b9cf3f4ed8aa0ce10ab7d35eaaab..ebeaea9156bd9ee5ab1ac00e4e6836a67025e561 100755 (executable)
@@ -861,27 +861,6 @@ else:
        #this can be problematic if xmllint changes their output
        xmllint_capable=True
 
-
-def x11_deprecation_check(depstr):
-       if depstr.find("virtual/x11") == -1:
-               return False
-       depsplit = depstr.split()
-       ok_stack = []
-       ok = False
-       for token in depsplit:
-               if token == "(":
-                       ok_stack.append(ok)
-                       ok = False
-               elif token == ")":
-                       ok = ok_stack.pop()
-               elif token == "||":
-                       ok = True
-               else:
-                       ok = False
-                       if token.find("virtual/x11") != -1 and (not ok_stack or not ok_stack[-1]):
-                               return True
-       return False
-
 if options.mode == 'commit':
        retval = ("","")
        if isCvs:
@@ -1443,11 +1422,6 @@ for x in scanlist:
                badlicsyntax = badlicsyntax > 0
                badprovsyntax = badprovsyntax > 0
 
-               if not baddepsyntax:
-                       if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
-                               stats["usage.obsolete"] += 1
-                               fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
-
                # uselist checks - global
                myuse = []
                default_use = []