dev-db/mycli: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 8 Mar 2020 08:17:38 +0000 (09:17 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 8 Mar 2020 08:25:06 +0000 (09:25 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-db/mycli/Manifest
dev-db/mycli/mycli-1.19.0.ebuild [deleted file]

index f1c96e7851bf32799eca956249832f280668126c..1f52fa521b65eca2d9689c8e81004fbac2bd926c 100644 (file)
@@ -1,2 +1 @@
-DIST mycli-1.19.0.tar.gz 263255 BLAKE2B 524190429476793af038c8302f43389884a6ee24a05b0b8c739f290dbfdebec3336bd14567eafff2ea3351430791e4844e16dfc5affb1b28bb57d3759b496350 SHA512 8c6003a09a888c2ac6f35a881ca072ba8972f66b13319cbff73f7a525d1f808b767dcef0121b6272a1b82eed1a02c8c417d5805e5a8ce0c141545f28ff3c3a33
 DIST mycli-1.20.1.tar.gz 265264 BLAKE2B d00b1713132609b0a5ec6e8b78785fdab5c6b4db5937bc0b9bc69ddde90ad3dc75aeb99ccf6b5e7fe5e78e9bf4819f03fb454825e5182bc5d2c44356032343d1 SHA512 82ee642b2a4c158b0e2ea275941650125e15004ec1c70b2ab90ae0825090efccb4910a14fd46bcdf795a74adba5689b46de5668447308de63d1cbbbe2e6b0e9d
diff --git a/dev-db/mycli/mycli-1.19.0.ebuild b/dev-db/mycli/mycli-1.19.0.ebuild
deleted file mode 100644 (file)
index 2927d81..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
-
-HOMEPAGE="https://www.mycli.net"
-SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ssh test"
-RESTRICT="!test? ( test )"
-RDEPEND="
-       >=dev-python/cli_helpers-1.0.1[${PYTHON_USEDEP}]
-       >=dev-python/click-4.1[${PYTHON_USEDEP}]
-       >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
-       >=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
-       >=dev-python/prompt_toolkit-2.0.6[${PYTHON_USEDEP}]
-       >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
-       >=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}]
-       >=dev-python/python-sqlparse-0.2.2[${PYTHON_USEDEP}]
-       <dev-python/python-sqlparse-0.3.0[${PYTHON_USEDEP}]
-       ssh? ( dev-python/paramiko[${PYTHON_USEDEP}] )
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] ${RDEPEND} )"
-
-python_test() {
-       pytest --capture=sys \
-               --showlocals \
-               --doctest-modules \
-               --doctest-ignore-import-errors \
-               --ignore=setup.py \
-               --ignore=mycli/magic.py \
-               --ignore=mycli/packages/parseutils.py \
-               --ignore=test/features
-}