dev-perl/DBIx-Safe: EAPI6 + Tests
authorKent Fredric <kentnl@gentoo.org>
Fri, 20 Oct 2017 01:29:04 +0000 (14:29 +1300)
committerKent Fredric <kentnl@gentoo.org>
Fri, 20 Oct 2017 07:39:42 +0000 (20:39 +1300)
- EAPI6
- Enable tests
- Cleanup tests
- Document manual stuff
- Udpate remote-id's.

Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/DBIx-Safe/DBIx-Safe-1.2.5-r1.ebuild [new file with mode: 0644]
dev-perl/DBIx-Safe/metadata.xml

diff --git a/dev-perl/DBIx-Safe/DBIx-Safe-1.2.5-r1.ebuild b/dev-perl/DBIx-Safe/DBIx-Safe-1.2.5-r1.ebuild
new file mode 100644 (file)
index 0000000..dd738e5
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TURNSTEP
+DIST_VERSION=1.2.5
+inherit perl-module eutils
+
+DESCRIPTION="Safer access to your database through a DBI database handle"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="BSD-2"
+
+RDEPEND="dev-perl/DBI
+       dev-perl/DBD-Pg"
+DEPEND="${RDEPEND}"
+
+src_test() {
+       perl_rm_files t/02perlcritic.t
+       if [[ -z "${DBI_DSN}" ]]; then
+               ewarn "Comprehensive testing of this package requires some manual configuration."
+               ewarn "For details, see:"
+               ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/DBIx-Safe"
+       fi
+       perl-module_src_test
+}
index 2b9a936fc0a1933802b5db1fa4b28a53939f2a4e..924a4f01a129ea8d2f02c85b63d4d5cb178c1ad0 100644 (file)
@@ -5,4 +5,8 @@
     <email>perl@gentoo.org</email>
     <name>Gentoo Perl Project</name>
   </maintainer>
+  <upstream>
+    <remote-id type="cpan">DBIx-Safe</remote-id>
+    <remote-id type="cpan-module">DBIx::Safe</remote-id>
+  </upstream>
 </pkgmetadata>