dev-python/pytest-runner: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 7 Mar 2020 15:34:00 +0000 (16:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 7 Mar 2020 15:34:00 +0000 (16:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-runner/Manifest
dev-python/pytest-runner/pytest-runner-4.2.ebuild [deleted file]

index 339a4428076937c3765997c832f1b0d9ee7f2640..19e68b277ebc3d272f7ef29beeba63633a138d75 100644 (file)
@@ -1,2 +1 @@
-DIST pytest-runner-4.2.tar.gz 11947 BLAKE2B 97495bead800a81d879659f1ee522822f76fe8ac80579537d43e21e663323d7c10be8d2da7d05ffdb0931145149d8c10ef7c72b3ab4da2ce856d44d3f00a724e SHA512 278da7add27f77134e63470747ffd9fe663d93ab8e7cebfbae98902bb1d5ffba45277574107f958255251cb9e499b85a0db3e8173f9f10fb31d1561ca709a379
 DIST pytest-runner-5.2.tar.gz 15534 BLAKE2B 0bcbd5991808aaa4b85b9071ce142e03287683e919687fa76f5b7929ad07dca6ae6edaf7ad30a1bc1ba0163f43505ec18ab2cd5e0462399b8252c8ca761d7b29 SHA512 5fc62a4e681cfa0ef25dc815ccbbfe1a7ca0e9e7783c2ba2db0da7d2539f11c08d6c3fad2ab3dfe7f0d50fe7bfb41127b11ec9af67ef8e32361655bc910c8245
diff --git a/dev-python/pytest-runner/pytest-runner-4.2.ebuild b/dev-python/pytest-runner/pytest-runner-4.2.ebuild
deleted file mode 100644 (file)
index d306245..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Adds support for tests during installation of setup.py files"
-HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/jaraco-packaging[${PYTHON_USEDEP}]
-               dev-python/rst-linker[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-       )
-       test? ( ${RDEPEND} )
-"
-
-# Tests require network access to download packages
-RESTRICT="test"
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_sphinx
-               HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
-       fi
-}
-
-python_test() {
-       esetup.py pytest
-}