app-emulation/spice: Various 9999 updates and fixes
authorJames Le Cuirot <chewi@gentoo.org>
Fri, 27 Mar 2020 09:30:09 +0000 (09:30 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Fri, 27 Mar 2020 09:30:09 +0000 (09:30 +0000)
This includes adding the opus USE flag, dropping the celt option,
fixing static library handling, and disabling the tests.

Package-Manager: Portage-2.3.96, Repoman-2.3.20
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
app-emulation/spice/spice-9999.ebuild

index 6390d08a37a5a13aba11f74e5c806598d17452b2..b2b42811ca6b17308270dfaf60d0119e310d8b4a 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit eutils git-r3 meson python-any-r1 readme.gentoo-r1 xdg-utils
+inherit git-r3 meson python-any-r1 readme.gentoo-r1 xdg-utils
 
 DESCRIPTION="SPICE server"
 HOMEPAGE="https://www.spice-space.org/"
@@ -14,19 +14,19 @@ EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice.git"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS=""
-IUSE="libressl lz4 sasl smartcard gstreamer"
+IUSE="gstreamer libressl lz4 opus sasl smartcard static-libs"
 
 # the libspice-server only uses the headers of libcacard
 RDEPEND="
        dev-lang/orc
        >=dev-libs/glib-2.22:2
-       media-libs/opus
        sys-libs/zlib
        virtual/jpeg:0=
        >=x11-libs/pixman-0.17.7
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:0= )
        lz4? ( app-arch/lz4:0= )
+       opus? ( media-libs/opus )
        smartcard? ( >=app-emulation/libcacard-0.1.2 )
        sasl? ( dev-libs/cyrus-sasl )
        gstreamer? (
@@ -43,6 +43,12 @@ BDEPEND="${PYTHON_DEPS}
                dev-python/six[${PYTHON_USEDEP}]
        ')"
 
+DOCS=(
+       AUTHORS
+       CHANGELOG.md
+       README
+)
+
 python_check_deps() {
        has_version -b ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
        has_version -b "dev-python/six[${PYTHON_USEDEP}]"
@@ -56,16 +62,19 @@ src_configure() {
        # Prevent sandbox violations, bug #586560
        # https://bugzilla.gnome.org/show_bug.cgi?id=744134
        # https://bugzilla.gnome.org/show_bug.cgi?id=744135
-       addpredict /dev
+       use gstreamer && addpredict /dev
 
        xdg_environment_reset
 
        local emesonargs=(
+               -Ddefault_library=$(usex static-libs both shared)
+               -Dgstreamer=$(usex gstreamer 1.0 no)
                $(meson_use lz4)
                $(meson_use sasl)
+               $(meson_feature opus)
                $(meson_feature smartcard)
-               -Dgstreamer=$(usex gstreamer "1.0" "no")
-               -Dcelt051=disabled
+               -Dmanual=false
+               -Dtests=false
        )
        meson_src_configure
 }
@@ -74,13 +83,14 @@ src_compile() {
        # Prevent sandbox violations, bug #586560
        # https://bugzilla.gnome.org/show_bug.cgi?id=744134
        # https://bugzilla.gnome.org/show_bug.cgi?id=744135
-       addpredict /dev
+       use gstreamer && addpredict /dev
 
        meson_src_compile
 }
 
 src_install() {
        meson_src_install
+       einstalldocs
        readme.gentoo_create_doc
 }