dev-ml/ocamlbuild: remove old
authorAlexis Ballier <aballier@gentoo.org>
Tue, 3 May 2016 10:38:38 +0000 (12:38 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 3 May 2016 10:40:50 +0000 (12:40 +0200)
Package-Manager: portage-2.2.28

dev-ml/ocamlbuild/Manifest
dev-ml/ocamlbuild/files/installbin.patch [deleted file]
dev-ml/ocamlbuild/ocamlbuild-0.9.1.ebuild [deleted file]

index d7ccb433cfbae0b6834097f751c9ca0f5e09cddc..ad244e5c29b6fbe20bf7bfd912d2b1540711e301 100644 (file)
@@ -1,2 +1 @@
-DIST ocamlbuild-0.9.1.tar.gz 160896 SHA256 7a31fde2d863768372851665e3ce64064c35e38d2b2f3cbd060a6df426f16ee8 SHA512 07da313f896fd31fab42881515f33544a587f831aa0928540af2351bf8d59b14115a144b17d156cb2599ce5d568684192a922f9f85f86ddd7299b8e194fd85c6 WHIRLPOOL f28e3ce19371dc26d6992035e47a72cb82adde2869dd5188a8ea0ed6aee481633e0ada4ec28428a2f58e51582f60c3a486066d0f7e09dda4e8c374f977f420a8
 DIST ocamlbuild-0.9.2.tar.gz 163014 SHA256 257a3961da1aa47deb3de8da238ebe1daf13a73efef2228f97a064a90f91c6bc SHA512 6f6fa2ca0030256b61a9f93275f26327a032594a1ddd288e1eb9f4c41dfc139e4cdb6cd66ae8e383dd2f8aabb435181abfbf6b4aa0892ef6fa420c29e33b391a WHIRLPOOL 4b1285a3177787c9d4d1e4581dec4079a1144568512c8871b2ed9436bea941c9447130af616c418d7c18157f0818de26f6344635c7e63e4ec13acaa5229cf77a
diff --git a/dev-ml/ocamlbuild/files/installbin.patch b/dev-ml/ocamlbuild/files/installbin.patch
deleted file mode 100644 (file)
index e7bd2cf..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ocamlbuild-0.9.1/Makefile
-===================================================================
---- ocamlbuild-0.9.1.orig/Makefile
-+++ ocamlbuild-0.9.1/Makefile
-@@ -202,7 +202,7 @@ beforedepend:: src/ocamlbuild_config.ml
- install-bin-byte:
-       mkdir -p $(INSTALL_BINDIR)
-       $(CP) ocamlbuild.byte $(INSTALL_BINDIR)/ocamlbuild.byte$(EXE)
--ifeq ($(OCAML_NATIVE), true)
-+ifneq ($(OCAML_NATIVE), true)
-       $(CP) ocamlbuild.byte $(INSTALL_BINDIR)/ocamlbuild$(EXE)
- endif
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.9.1.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.9.1.ebuild
deleted file mode 100644 (file)
index 354981b..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="OCamlbuild"
-HOMEPAGE="https://github.com/ocaml/ocamlbuild"
-SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="+ocamlopt"
-
-DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
-RDEPEND="${DEPEND}
-       !<dev-ml/findlib-1.6.1-r1
-"
-
-src_prepare() {
-       epatch "${FILESDIR}/installbin.patch"
-}
-
-src_configure() {
-       emake -f configure.make Makefile.config \
-               PREFIX="${EPREFIX}/usr" \
-               BINDIR="${EPREFIX}/usr/bin" \
-               LIBDIR="$(ocamlc -where)" \
-               OCAML_NATIVE=$(usex ocamlopt true false) \
-               OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
-               NATDYNLINK=$(usex ocamlopt true false)
-}
-
-src_install() {
-       emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
-       dodoc Changes
-}