net-misc/scponly: [QA] Add missing dependency on net-misc/unison.
authorUlrich Müller <ulm@gentoo.org>
Tue, 19 Nov 2019 15:13:44 +0000 (16:13 +0100)
committerUlrich Müller <ulm@gentoo.org>
Tue, 19 Nov 2019 15:17:04 +0000 (16:17 +0100)
Update ebuild to EAPI 7, which also fixes QA issue with estack.eclass.

Rename hard-coded path in pkg_config from /bin/passwd to /usr/bin/passwd
which should always exist.

Closes: https://bugs.gentoo.org/670430
Closes: https://bugs.gentoo.org/680570
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
net-misc/scponly/files/scponly-4.8-gcc4.4.0.patch
net-misc/scponly/scponly-4.8-r6.ebuild [moved from net-misc/scponly/scponly-4.8-r5.ebuild with 95% similarity]

index d08ce28b93b580a76f80b4cc77ae4894d9383da7..8bb689f5914d7de3d4d66c00225fe314e61a6823 100644 (file)
@@ -1,5 +1,7 @@
---- helper.c.orig      2009-05-11 00:33:08.000000000 -0600
-+++ helper.c   2009-05-11 00:39:59.000000000 -0600
+https://bugs.gentoo.org/269242
+
+--- scponly-4.8.orig/helper.c
++++ scponly-4.8/helper.c
 @@ -259,11 +259,11 @@
                                                        PROG_RSYNC, logstamp());
                                                return 1;
similarity index 95%
rename from net-misc/scponly/scponly-4.8-r5.ebuild
rename to net-misc/scponly/scponly-4.8-r6.ebuild
index 2e53a29f08707186bc138a53e521757ed38edb69..b3068376ead55f4dd1a33a993c2e4b3dec58ae69 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit eutils multilib readme.gentoo toolchain-funcs user
+EAPI=7
+
+inherit multilib readme.gentoo-r1 toolchain-funcs user
 
 DESCRIPTION="A tiny pseudoshell which only permits scp and sftp"
 HOMEPAGE="https://github.com/scponly/scponly"
@@ -22,6 +23,7 @@ RDEPEND="
        quota? ( sys-fs/quota )
        rsync? ( net-misc/rsync )
        subversion? ( dev-vcs/subversion )
+       unison? ( net-misc/unison:= )
 "
 DEPEND="${RDEPEND}"
 
@@ -29,6 +31,11 @@ myuser="scponly"
 myhome="/home/${myuser}"
 mysubdir="/pub"
 
+PATCHES=(
+       "${FILESDIR}/${P}-rsync.patch"
+       "${FILESDIR}/${P}-gcc4.4.0.patch"
+)
+
 DOC_CONTENTS="
        You might want to run\n
        emerge --config =${CATEGORY}/${PF}\n
@@ -37,12 +44,6 @@ DOC_CONTENTS="
        the SECURITY file.
 "
 
-src_prepare() {
-       epatch "${FILESDIR}/${P}-rsync.patch"
-       # bug #269242
-       epatch "${FILESDIR}/${P}-gcc4.4.0.patch"
-}
-
 src_configure() {
        CFLAGS="${CFLAGS} ${LDFLAGS}" econf \
                --with-sftp-server="/usr/$(get_libdir)/misc/sftp-server" \
@@ -126,7 +127,7 @@ pkg_config() {
 
        # passwd compatibility
        if has_version "=${CATEGORY}/${PF}[passwd]" ; then
-               BINARIES="${BINARIES} /bin/passwd"
+               BINARIES="${BINARIES} /usr/bin/passwd"
        fi
 
        # quota compatibility
@@ -197,7 +198,7 @@ pkg_config() {
        for BIN in ${BINARIES}; do
                einfo "Install ${BIN}"
                install -o0 -g0 -m0755 -d "${myhome}$(dirname ${BIN})"
-               if [ "${BIN}" = "/bin/passwd" ]; then  # needs suid
+               if [ "${BIN}" = "/usr/bin/passwd" ]; then  # needs suid
                        install -p -o0 -g0 -m04711 "${BIN}" "${myhome}/${BIN}"
                else
                        install -p -o0 -g0 -m0755 "${BIN}" "${myhome}/${BIN}"