dev-python/vcversioner: Add pypy support
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 10:53:11 +0000 (12:53 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 11:05:34 +0000 (13:05 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/vcversioner/vcversioner-2.14.0.0.ebuild

index 5638db24770848fd476a7f4b0c76e52a343de9b0..c2c33998e41d58c399dd6aff6fe895301738f145 100644 (file)
@@ -4,15 +4,27 @@
 
 EAPI=5
 
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
 
 inherit distutils-r1
 
 DESCRIPTION="Use version control tags to discover version numbers"
-HOMEPAGE="https://github.com/habnabit/vcversioner"
+HOMEPAGE="https://github.com/habnabit/vcversioner https://pypi.python.org/pypi/vcversioner"
 SRC_URI="mirror://pypi/v/${PN}/${P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+       "
+
+# not included
+RESTRICT=test
+
+python_test() {
+       py.test || die
+}