net-libs/libnftnl: Version bump
authorManuel Rüger <mrueg@gentoo.org>
Thu, 17 Sep 2015 08:47:12 +0000 (10:47 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Thu, 17 Sep 2015 08:47:12 +0000 (10:47 +0200)
Package-Manager: portage-2.2.20.1

net-libs/libnftnl/Manifest
net-libs/libnftnl/libnftnl-1.0.4.ebuild [new file with mode: 0644]

index 6bece668805c79e18d7a80060679b49360532af7..4853992d503f512c0b7dc4f20c404eed31afc00f 100644 (file)
@@ -1 +1,2 @@
 DIST libnftnl-1.0.3.tar.bz2 356264 SHA256 cf0ae7eab6a6866192a1fbd6b370a8a2cbe2066fe3975ab44939fd50747c27f7 SHA512 6fba3f3a0c3d98e0c3200edbd45910e326f0864383dc695fa77580d47d3fe541c50518f62d2dbfc50b2378b9b311aec28b3321ef18f59a321e0a3f0817952181 WHIRLPOOL 70219737c4d865bdfe9f58803377d3a10619198cb486623d03d30a43b0d159ded9d625505cb0209fe30585dbe3413d136d2fdd6552a6ce2339151bedb1c94c9a
+DIST libnftnl-1.0.4.tar.bz2 367016 SHA256 8f1fbf9bcf87bf68e782f464fb05428d476c2e9a0bec91c6cda7a389a21969d0 SHA512 ed4230581c139c004c39a9ef3e6d548cfad43d1f3c47e83db328b7ae6c6d7fa70b194699d7f18472fa7fb819c943a85b6997be0f2d2b926745dd5cdbdbf81a41 WHIRLPOOL f899694c2d45fc073af694f5bd6edcae70abead69ef37a3f84a290e6b3dbb246029337e14378e4b3af4a4040f9c407db247f4d8636b8986e3f0d5b48783c20bd
diff --git a/net-libs/libnftnl/libnftnl-1.0.4.ebuild b/net-libs/libnftnl/libnftnl-1.0.4.ebuild
new file mode 100644 (file)
index 0000000..32b072d
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base linux-info toolchain-funcs
+
+DESCRIPTION="Netlink API to the in-kernel nf_tables subsystem"
+HOMEPAGE="http://netfilter.org/projects/nftables/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples json static-libs test xml"
+SRC_URI="http://netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+RDEPEND=">=net-libs/libmnl-1.0.0
+       xml? ( >=dev-libs/mini-xml-2.6 )
+       json? ( >=dev-libs/jansson-2.3 )"
+DEPEND="virtual/pkgconfig
+       ${RDEPEND}"
+
+REQUIRED_USE="test? ( json xml )"
+
+pkg_setup() {
+       if kernel_is ge 3 13; then
+               CONFIG_CHECK="~NF_TABLES"
+               linux-info_pkg_setup
+       else
+               eerror "This package requires kernel version 3.13 or newer to work properly."
+       fi
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               $(use_with xml xml-parsing) \
+               $(use_with json json-parsing)
+}
+
+src_install() {
+       default
+       gen_usr_ldscript -a nftnl
+       prune_libtool_files
+
+       if use examples; then
+               find examples/ -name 'Makefile*' -delete
+               dodoc -r examples/
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}
+
+src_test() {
+       default
+       cd tests || die
+       ./test-script.sh || die
+}