dev-vcs/mercurial: Bump to version 4.3.2
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 19 Sep 2017 22:03:49 +0000 (00:03 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 19 Sep 2017 22:13:00 +0000 (00:13 +0200)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-vcs/mercurial/Manifest
dev-vcs/mercurial/mercurial-4.3.2.ebuild [new file with mode: 0644]

index f40206246f7668566c270963bac6d21f91c9069e..e7e2deeac2a68914a9fc0ae706389b7fd3cb6db1 100644 (file)
@@ -5,4 +5,5 @@ DIST mercurial-4.2.2.tar.gz 5319282 SHA256 b20132dec5ae6d27ee43a133144069895befe
 DIST mercurial-4.2.3.tar.gz 5322850 SHA256 04908fc7d89e5810edf3d2762f5aecce5b5c0cb8534f3dbff7d0d848d11ff7ac SHA512 d6c4bf4fd38eaaee8cf2e5c30cd8f15c3651992d27bf4431ab42dffde7dfc06eb59641d9e7087f7851580b1740a84a8806169d8f224cd0d6ce1fb0b167a97647 WHIRLPOOL bc3c0cdbe88441f9d4349b174b65e032d2150a52c07450982d2f28b14ef0ed0629ef4df859581a4b5873cc8712857c40854bd013d6299b65d0f0b5317ee52e99
 DIST mercurial-4.2.tar.gz 5303367 SHA256 23a412308fc9c2b354a0e91a89588a4af2af061b47da80bc4233ccb0cceef47d SHA512 bd03134a70fe0576a31d86cb6ca2d232b8f98bd9b038dc972a4d332889bb39c776f47d44ea9c45588d6e53590a8e3fbd48ca25238525919b8e44beab3d3c79cb WHIRLPOOL 930882698c0e662f5fadc8a57a14ce00270cce70f7a9f8f0081647a28c3558aeda1a4d7bc5aa7e264cb60ec85051dae6a16cc62df0f51be3cc406bf587ff5485
 DIST mercurial-4.3.1.tar.gz 5475042 SHA256 2b12f02e3a452adff4ec9cf007017bab0cadb3f37eaf12f4b25a662df73618a2 SHA512 4c42d06b7f111a3e825dd927704a30f88f0b2225cf87ab8954bf53a7fbc0edf561374dd49b13d9c10140d98ff5853a64acb5a744349727abae81d32da401922b WHIRLPOOL 4360763be405d75ffc0e3e2356fcfe44079bf9818c07211964ba7433932956283feb329379af329e0a7d70acc5c6a163a9c08976abb902197d6a6f0180a3a958
+DIST mercurial-4.3.2.tar.gz 5491214 SHA256 0f5bf688ba2add6f5db98a633edef43411ecf2c7ada5f2e14b9265820a96cd48 SHA512 e69b7cff941d83531d59d91c30e336807f868302dfda565e1421b7d34c2769221220686774af236d86ac0f67dba6e8a0947ed1185b30d89463a8d211e20d1cbc WHIRLPOOL 079d05e75cde63ff907b485a45a6a9cf8b42001525a799939647d05dd60d85c1faa0cbf14b9da95488103ec9f0b177f59ad7d8bde93dca3ffe428d697669bd4e
 DIST mercurial-4.3.tar.gz 5469979 SHA256 ebf11176e9b5354ec7a1bde6c5382c914d10c397410531faf89f8b5124a7cb65 SHA512 d74ae5f35d8c415c07737b59e6c5455963dfbf5d038c43d683fd34dd84423b9ccf9cd670667f458db20d8580fc7c7d9e5609d29d990e1e94683734694211c417 WHIRLPOOL 54583dbc826fdec3e737dc49d1a8ce180d29579d091c86e48a3b7c68bb4a2d399c5aff3b2ff0e30cd911e8955537a621c73c330d70a55f7efcdeafd21257178f
diff --git a/dev-vcs/mercurial/mercurial-4.3.2.ebuild b/dev-vcs/mercurial/mercurial-4.3.2.ebuild
new file mode 100644 (file)
index 0000000..a04546c
--- /dev/null
@@ -0,0 +1,134 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="https://www.mercurial-scm.org/"
+SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bugzilla emacs gpg test tk"
+
+RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+       gpg? ( app-crypt/gnupg )
+       tk? ( dev-lang/tk )
+       app-misc/ca-certificates"
+DEPEND="emacs? ( virtual/emacs )
+       test? ( app-arch/unzip
+               dev-python/pygments[${PYTHON_USEDEP}] )"
+
+SITEFILE="70${PN}-gentoo.el"
+
+PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )
+
+python_prepare_all() {
+       # fix up logic that won't work in Gentoo Prefix (also won't outside in
+       # certain cases), bug #362891
+       sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+       strip-flags -ftracer -ftree-vectorize
+       # Note: make it impl-conditional if py3 is supported
+       append-flags -fno-strict-aliasing
+
+       "${PYTHON}" setup.py build_mo || die
+}
+
+python_compile_all() {
+       rm -r contrib/{win32,macosx} || die
+       if use emacs; then
+               cd contrib || die
+               elisp-compile mercurial.el || die "elisp-compile failed!"
+       fi
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       newbashcomp contrib/bash_completion hg
+
+       insinto /usr/share/zsh/site-functions
+       newins contrib/zsh_completion _hg
+
+       rm -f doc/*.?.txt
+       dodoc CONTRIBUTORS
+       cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
+
+       dobin hgeditor
+       dobin contrib/hgk
+       python_foreach_impl python_doscript contrib/hg-ssh
+
+       if use emacs; then
+               elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+               elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+       fi
+
+       local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
+                         *.el mercurial.spec)
+       for f in ${RM_CONTRIB[@]}; do
+               rm -r contrib/$f || die
+       done
+
+       dodoc -r contrib
+       docompress -x /usr/share/doc/${PF}/contrib
+       doman doc/*.?
+
+       insinto /etc/mercurial/hgrc.d
+       doins "${FILESDIR}/cacerts.rc"
+}
+
+src_test() {
+       pushd tests &>/dev/null || die
+       rm -rf *svn*                    # Subversion tests fail with 1.5
+       rm -f test-archive*             # Fails due to verbose tar output changes
+       rm -f test-convert-baz*         # GNU Arch baz
+       rm -f test-convert-cvs*         # CVS
+       rm -f test-convert-darcs*       # Darcs
+       rm -f test-convert-git*         # git
+       rm -f test-convert-mtn*         # monotone
+       rm -f test-convert-tla*         # GNU Arch tla
+       #rm -f test-doctest*            # doctest always fails with python 2.5.x
+       rm -f test-largefiles*          # tends to time out
+
+       popd &>/dev/null || die
+       distutils-r1_src_test
+}
+
+python_test() {
+       local TEST_DIR
+
+       rm -rf "${TMPDIR}"/test
+       distutils_install_for_testing
+       cd tests || die
+       "${PYTHON}" run-tests.py --verbose \
+               --tmpdir="${TMPDIR}"/test \
+               --with-hg="${TEST_DIR}"/scripts/hg \
+               || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+
+       elog "If you want to convert repositories from other tools using convert"
+       elog "extension please install correct tool:"
+       elog "  dev-vcs/cvs"
+       elog "  dev-vcs/darcs"
+       elog "  dev-vcs/git"
+       elog "  dev-vcs/monotone"
+       elog "  dev-vcs/subversion"
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}