Initial commit of istack-commons-runtime.
authorKrzysztof Pawlik <nelchael@gentoo.org>
Tue, 1 May 2007 18:32:36 +0000 (18:32 +0000)
committerKrzysztof Pawlik <nelchael@gentoo.org>
Tue, 1 May 2007 18:32:36 +0000 (18:32 +0000)
Package-Manager: portage-2.1.2.5

dev-java/istack-commons-runtime/ChangeLog [new file with mode: 0644]
dev-java/istack-commons-runtime/files/digest-istack-commons-runtime-20070122 [new file with mode: 0644]
dev-java/istack-commons-runtime/istack-commons-runtime-20070122.ebuild [new file with mode: 0644]
dev-java/istack-commons-runtime/metadata.xml [new file with mode: 0644]

diff --git a/dev-java/istack-commons-runtime/ChangeLog b/dev-java/istack-commons-runtime/ChangeLog
new file mode 100644 (file)
index 0000000..4661a40
--- /dev/null
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/istack-commons-runtime
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/istack-commons-runtime/ChangeLog,v 1.1 2007/05/01 18:32:36 nelchael Exp $
+
+*istack-commons-runtime-20070122 (01 May 2007)
+
+  01 May 2007; Krzysiek Pawlik <nelchael@gentoo.org> +metadata.xml,
+  +istack-commons-runtime-20070122.ebuild:
+  Initial commit of istack-commons-runtime.
+
diff --git a/dev-java/istack-commons-runtime/files/digest-istack-commons-runtime-20070122 b/dev-java/istack-commons-runtime/files/digest-istack-commons-runtime-20070122
new file mode 100644 (file)
index 0000000..89f989f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 22e3934dc7529c83b0c35e279fc188ce istack-commons-20070122.tar.bz2 10360
+RMD160 cb281316a6342a2da3372ed014a4734286522ab1 istack-commons-20070122.tar.bz2 10360
+SHA256 dc8c86bb11f7ddd4c1c50ca0925d59ade16b5dc74bcd983fe95a08e104662a8e istack-commons-20070122.tar.bz2 10360
diff --git a/dev-java/istack-commons-runtime/istack-commons-runtime-20070122.ebuild b/dev-java/istack-commons-runtime/istack-commons-runtime-20070122.ebuild
new file mode 100644 (file)
index 0000000..8f6be26
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/istack-commons-runtime/istack-commons-runtime-20070122.ebuild,v 1.1 2007/05/01 18:32:36 nelchael Exp $
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="istack-commons"
+HOMEPAGE="https://istack-commons.dev.java.net/"
+SRC_URI="http://overlays.gentoo.org/svn/proj/java/wsdp-overlay/distfiles/istack-commons-${PV}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/sun-jaf"
+
+DEPEND=">=virtual/jdk-1.5
+       ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+       ${COMMON_DEP}"
+
+S="${WORKDIR}/istack-commons-${PV}"
+
+src_unpack() {
+       unpack ${A}
+
+       java-ant_bsfix_one "${S}/build-common.xml"
+
+       java-pkg_jarfrom --into "${S}/runtime/lib" sun-jaf
+}
+
+EANT_BUILD_XML="runtime/build.xml"
+
+src_install() {
+
+       java-pkg_dojar runtime/build/istack-commons-runtime.jar
+
+       use source && java-pkg_dosrc runtime/src/*
+}
diff --git a/dev-java/istack-commons-runtime/metadata.xml b/dev-java/istack-commons-runtime/metadata.xml
new file mode 100644 (file)
index 0000000..39fffcd
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>java</herd>
+  <maintainer>
+    <email>nelchael@gentoo.org</email>
+  </maintainer>
+</pkgmetadata>