net-misc/quagga: bump EAPI to 7
authorSergey Popov <pinkbyte@gentoo.org>
Sun, 8 Mar 2020 16:28:47 +0000 (19:28 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Sun, 8 Mar 2020 16:32:39 +0000 (19:32 +0300)
Migrate away from user and ltprune eclasses

Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Package-Manager: Portage-2.3.89, Repoman-2.3.11

net-misc/quagga/quagga-1.2.4.ebuild

index 7ae80aba93424cb70fc8974cf50a6e3418065bfb..277218d6412bc3cb265beaf013ef80bb0f8be74a 100644 (file)
@@ -1,11 +1,11 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
 
-inherit autotools eutils flag-o-matic ltprune multilib pam readme.gentoo-r1 systemd tmpfiles user
+inherit autotools eutils flag-o-matic multilib pam readme.gentoo-r1 systemd tmpfiles
 
 DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP"
 HOMEPAGE="https://www.quagga.net/"
@@ -20,6 +20,8 @@ IUSE="bgpclassless caps fpm doc elibc_glibc ipv6 multipath nhrpd ospfapi pam pro
 RESTRICT="!test? ( test )"
 
 COMMON_DEPEND="
+       acct-group/quagga
+       acct-user/quagga
        caps? ( sys-libs/libcap )
        nhrpd? ( net-dns/c-ares:0= )
        protobuf? ( dev-libs/protobuf-c:0= )
@@ -48,11 +50,6 @@ starting one of the daemons.
 You can pass additional options to the daemon by setting the EXTRA_OPTS
 variable in their respective file in /etc/conf.d"
 
-pkg_setup() {
-       enewgroup quagga
-       enewuser quagga -1 -1 /var/empty quagga
-}
-
 src_prepare() {
        # Classless prefixes for BGP
        # http://hasso.linux.ee/doku.php/english:network:quagga
@@ -103,7 +100,7 @@ src_configure() {
 
 src_install() {
        default
-       prune_libtool_files
+       find "${D}" -name '*.la' -delete || die
        readme.gentoo_create_doc
 
        keepdir /etc/quagga