net-analyzer/iptraf-ng: Update live ebuild
authorJeroen Roovers <jer@gentoo.org>
Sat, 2 Nov 2019 13:40:07 +0000 (14:40 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 2 Nov 2019 13:44:17 +0000 (14:44 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Fixes: https://bugs.gentoo.org/656982
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/iptraf-ng/iptraf-ng-9999.ebuild

index ea4ed84750bc519d2acf794b8f5fdaf3c7510f8b..284d4bb322e47d3a8f6e20c886bed832a9483154 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit eutils git-r3 toolchain-funcs
+EAPI=7
+inherit git-r3 toolchain-funcs
 
 DESCRIPTION="A console-based network monitoring utility"
-HOMEPAGE="http://fedorahosted.org/iptraf-ng/"
-EGIT_REPO_URI="https://git.fedorahosted.org/git/iptraf-ng.git"
+HOMEPAGE="https://github.com/iptraf-ng/iptraf-ng"
+EGIT_REPO_URI="https://github.com/iptraf-ng/iptraf-ng"
 
 LICENSE="GPL-2 doc? ( FDL-1.1 )"
 SLOT="0"
@@ -25,6 +25,8 @@ DEPEND="
 "
 
 src_prepare() {
+       default
+
        sed -i \
                -e '/^CC =/d' \
                -e '/^CFLAGS/s:= -g -O2:+= :' \
@@ -54,7 +56,11 @@ src_install() {
 
        doman src/*.8
        dodoc AUTHORS CHANGES FAQ README* RELEASE-NOTES
-       use doc && dohtml -a gif,html,png -r Documentation/*
+
+       if use doc; then
+               docinto html
+               dodoc -r Documentation
+       fi
 
        keepdir /var/{lib,log}/iptraf-ng #376157
 }