media-fonts/ekushey-bangla-fonts: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 19 Oct 2019 18:44:20 +0000 (20:44 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 19 Oct 2019 18:53:51 +0000 (20:53 +0200)
Bug: https://bugs.gentoo.org/697302
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-fonts/ekushey-bangla-fonts/ekushey-bangla-fonts-20070420.ebuild

index 0b2d2ee5408df5a91db4114b81d9c316e5f9daff..67591655647ac0d0ec309f59b3a17fc32fad8911 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit font
 
@@ -31,26 +31,17 @@ SRC_URI="mirror://sourceforge/ekushey/${P_LOHIT}.ttf
        mirror://sourceforge/ekushey/${P_SOLAIMANLIPI}.ttf
        mirror://sourceforge/ekushey/${P_RUPALI}.ttf"
 
-LICENSE="GPL-2 OFL-1.1"
+LICENSE="GPL-2+ OFL"
 SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE=""
 
-DEPEND=""
-RDEPEND=""
-
-FONT_S="${WORKDIR}"
-S="${FONT_S}"
 FONT_SUFFIX="ttf"
 
 src_unpack() {
-       cd "${S}"
-       for DISTFILE in ${A}
-       do
-               [[ "${DISTFILE}" =~ ([A-Za-z]+) ]]
-               local FONTNAME="${BASH_REMATCH[1]}"
-               cp -a "${DISTDIR}/${DISTFILE}" "${S}/${FONTNAME}.ttf"
+       local f
+       mkdir "${S}" || die
+       for f in ${A}; do
+               cp "${DISTDIR}/${f}" "${S}/${f%%[_-]*}.ttf"
        done
 }
-
-DOCS=""