dev-vcs/git: gitview has been removed (bug #610946).
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 26 Feb 2017 11:31:28 +0000 (12:31 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 26 Feb 2017 11:31:43 +0000 (12:31 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-vcs/git/git-2.12.0.ebuild
dev-vcs/git/git-9999-r1.ebuild
dev-vcs/git/git-9999-r2.ebuild
dev-vcs/git/git-9999-r3.ebuild
dev-vcs/git/git-9999.ebuild

index a1f5e74e5a896ea42eaa7e20f86bf909bfd8907d..0be668f04597a66f892dad8cacb101d7dad61212 100644 (file)
@@ -43,7 +43,7 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
                        cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
                        subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
                        )
-       python? ( gtk?
-       (
-               >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
-               >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
-       )
-               ${PYTHON_DEPS} )"
+       python? ( ${PYTHON_DEPS} )
+"
 
 # This is how info docs are created with Git:
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
        mediawiki-experimental? ( mediawiki )
        subversion? ( perl )
        webdav? ( curl )
-       gtk? ( python )
        python? ( ${PYTHON_REQUIRED_USE} )
 "
 
@@ -423,11 +418,6 @@ src_install() {
                elisp-site-file-install "${FILESDIR}"/${SITEFILE}
        fi
 
-       if use python && use gtk ; then
-               python_doscript "${S}"/contrib/gitview/gitview
-               dodoc "${S}"/contrib/gitview/gitview.txt
-       fi
-
        #dobin contrib/fast-import/git-p4 # Moved upstream
        #dodoc contrib/fast-import/git-p4.txt # Moved upstream
        newbin contrib/fast-import/import-tars.perl import-tars
index 996fd1fa4be43a0a0521082c413384a7b08f541e..6cc2e4ddc3f325aaa5180e48d666080ccfabe6e7 100644 (file)
@@ -43,7 +43,7 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
                        cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
                        subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
                        )
-       python? ( gtk?
-       (
-               >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
-               >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
-       )
-               ${PYTHON_DEPS} )"
+       python? ( ${PYTHON_DEPS} )
+"
 
 # This is how info docs are created with Git:
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
        mediawiki-experimental? ( mediawiki )
        subversion? ( perl )
        webdav? ( curl )
-       gtk? ( python )
        python? ( ${PYTHON_REQUIRED_USE} )
 "
 
@@ -423,11 +418,6 @@ src_install() {
                elisp-site-file-install "${FILESDIR}"/${SITEFILE}
        fi
 
-       if use python && use gtk ; then
-               python_doscript "${S}"/contrib/gitview/gitview
-               dodoc "${S}"/contrib/gitview/gitview.txt
-       fi
-
        #dobin contrib/fast-import/git-p4 # Moved upstream
        #dodoc contrib/fast-import/git-p4.txt # Moved upstream
        newbin contrib/fast-import/import-tars.perl import-tars
index 1924612f28b92156480143813a8718b25f1f4522..e9fecdd35ea2939a8977e899a50187d40a6e8607 100644 (file)
@@ -43,7 +43,7 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
                        cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
                        subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
                        )
-       python? ( gtk?
-       (
-               >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
-               >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
-       )
-               ${PYTHON_DEPS} )"
+       python? ( ${PYTHON_DEPS} )
+"
 
 # This is how info docs are created with Git:
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
        mediawiki-experimental? ( mediawiki )
        subversion? ( perl )
        webdav? ( curl )
-       gtk? ( python )
        python? ( ${PYTHON_REQUIRED_USE} )
 "
 
@@ -423,11 +418,6 @@ src_install() {
                elisp-site-file-install "${FILESDIR}"/${SITEFILE}
        fi
 
-       if use python && use gtk ; then
-               python_doscript "${S}"/contrib/gitview/gitview
-               dodoc "${S}"/contrib/gitview/gitview.txt
-       fi
-
        #dobin contrib/fast-import/git-p4 # Moved upstream
        #dodoc contrib/fast-import/git-p4.txt # Moved upstream
        newbin contrib/fast-import/import-tars.perl import-tars
index faa18537adff78fb0c2330b9a91de9af3dffcc4f..ede0b64737447084fd781e0f5b6262e1207b6170 100644 (file)
@@ -43,7 +43,7 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
                        cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
                        subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
                        )
-       python? ( gtk?
-       (
-               >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
-               >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
-       )
-               ${PYTHON_DEPS} )"
+       python? ( ${PYTHON_DEPS} )
+"
 
 # This is how info docs are created with Git:
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
        mediawiki-experimental? ( mediawiki )
        subversion? ( perl )
        webdav? ( curl )
-       gtk? ( python )
        python? ( ${PYTHON_REQUIRED_USE} )
 "
 
@@ -423,11 +418,6 @@ src_install() {
                elisp-site-file-install "${FILESDIR}"/${SITEFILE}
        fi
 
-       if use python && use gtk ; then
-               python_doscript "${S}"/contrib/gitview/gitview
-               dodoc "${S}"/contrib/gitview/gitview.txt
-       fi
-
        #dobin contrib/fast-import/git-p4 # Moved upstream
        #dodoc contrib/fast-import/git-p4.txt # Moved upstream
        newbin contrib/fast-import/import-tars.perl import-tars
index a1f5e74e5a896ea42eaa7e20f86bf909bfd8907d..0be668f04597a66f892dad8cacb101d7dad61212 100644 (file)
@@ -43,7 +43,7 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg gtk highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
@@ -75,12 +75,8 @@ RDEPEND="${CDEPEND}
                        cvs? ( >=dev-vcs/cvsps-2.1:0 dev-perl/DBI dev-perl/DBD-SQLite )
                        subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
                        )
-       python? ( gtk?
-       (
-               >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
-               >=dev-python/pygtksourceview-2.10.1-r1:2[${PYTHON_USEDEP}]
-       )
-               ${PYTHON_DEPS} )"
+       python? ( ${PYTHON_DEPS} )
+"
 
 # This is how info docs are created with Git:
 #   .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -112,7 +108,6 @@ REQUIRED_USE="
        mediawiki-experimental? ( mediawiki )
        subversion? ( perl )
        webdav? ( curl )
-       gtk? ( python )
        python? ( ${PYTHON_REQUIRED_USE} )
 "
 
@@ -423,11 +418,6 @@ src_install() {
                elisp-site-file-install "${FILESDIR}"/${SITEFILE}
        fi
 
-       if use python && use gtk ; then
-               python_doscript "${S}"/contrib/gitview/gitview
-               dodoc "${S}"/contrib/gitview/gitview.txt
-       fi
-
        #dobin contrib/fast-import/git-p4 # Moved upstream
        #dodoc contrib/fast-import/git-p4.txt # Moved upstream
        newbin contrib/fast-import/import-tars.perl import-tars