dev-ros/laser_proc: bump to 0.1.5
authorAlexis Ballier <aballier@gentoo.org>
Fri, 17 Aug 2018 12:52:34 +0000 (14:52 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 17 Aug 2018 13:07:58 +0000 (15:07 +0200)
Package-Manager: Portage-2.3.46, Repoman-2.3.10

dev-ros/laser_proc/Manifest
dev-ros/laser_proc/laser_proc-0.1.5.ebuild [new file with mode: 0644]

index 2588f3379b997ab028469291cc0875020eb31b96..d05420dc2df112c404cbf826658be14d6a513921 100644 (file)
@@ -1 +1,2 @@
 DIST laser_proc-0.1.4.tar.gz 6865 BLAKE2B 4709c976a3438a54f1e28f0e615bea503deeb5a3f54bae02804242dd54bd63e4418943309abe19cc34928ba3920bc7b84bc7ba8511a273357b3120c8221f0bdf SHA512 0a9ae28d9ad213f7227027c24b951d0a68799edc662e98e593090a7d01ab0a33671a2a26eeb3fdaf2f77a3d639a2274641c11e478c2f0689327a1fa66601b95a
+DIST laser_proc-0.1.5.tar.gz 6924 BLAKE2B 75b06134a1d4a68ad54447355962959e0ae9ba5f2df889b3740cc3dfed48ea3ae22e3098a7f0973ac4e0c6ec089eddb9fc7784aee96cac3662bef8a873c60735 SHA512 96062485b2ca7467aa5c54b04463fe89eb91a726ad79055831c7dc1dfad19e42b0759703eec5b659475ad1d09f95f3703b30343655e590db29100ee8b0ebaa87
diff --git a/dev-ros/laser_proc/laser_proc-0.1.5.ebuild b/dev-ros/laser_proc/laser_proc-0.1.5.ebuild
new file mode 100644 (file)
index 0000000..f21077e
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/laser_proc"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts representations of sensor_msgs/LaserScan and sensor_msgs/MultiEchoLaserScan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roscpp
+       dev-ros/rosconsole
+       dev-libs/console_bridge:=
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/pluginlib
+       dev-ros/nodelet
+       dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"