net-p2p/ncdc: Version bump. EAPI=6.
authorMichael Weber <xmw@gentoo.org>
Thu, 9 Mar 2017 13:40:05 +0000 (14:40 +0100)
committerMichael Weber <xmw@gentoo.org>
Thu, 9 Mar 2017 13:40:31 +0000 (14:40 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

net-p2p/ncdc/Manifest
net-p2p/ncdc/ncdc-1.20.ebuild [new file with mode: 0644]
net-p2p/ncdc/ncdc-9999.ebuild

index feb33b6ebc4a2a78be56369541b550c65118b5a9..01544e4a77fd57e98e5e0af45d0ac98e5f77a92a 100644 (file)
@@ -1 +1,2 @@
 DIST ncdc-1.19.1.tar.gz 354308 SHA256 a6b23381434a47f7134d9ebdf5658fd06768f9b5de498c43e0fa00d1c7229d47 SHA512 36eda8c582ddb40ef732151ecc1654eae927a6a004430d8d27528b3c57ae5e1b06c23a867d8e1624ee4365031325fd7ced2888dd64ff129431bba9ff4171f189 WHIRLPOOL eec4f206ffc15c2389855215c17dada8004200c4eaa5d54bb175296dccccd1fa9518b6a12798c72751896645ea4f77bae58708dee4743bef50c5af98e97af36e
+DIST ncdc-1.20.tar.gz 367688 SHA256 8a998857df6289b6bd44287fc06f705b662098189f2a8fe95b1a5fbc703b9631 SHA512 0f20d6584aab1e69bcb3a93271a8542c5968adee5fd198b375dc258996b60ee5f642eac5d5e91c5513e367bbfd42eda80ede9e6e93ab38279c33e8da557010a7 WHIRLPOOL 19452779f5c7559db27830cf64b079b4f98905fd9b64e98438745800a528867b444151d8d5c0f480083b1d59e73f120934d0a5bc091b815ee7b877158fe65572
diff --git a/net-p2p/ncdc/ncdc-1.20.ebuild b/net-p2p/ncdc/ncdc-1.20.ebuild
new file mode 100644 (file)
index 0000000..6868ec7
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="ncurses directconnect client"
+HOMEPAGE="http://dev.yorhel.nl/ncdc"
+SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="geoip"
+
+RDEPEND="app-arch/bzip2
+       dev-db/sqlite:3
+       dev-libs/glib:2
+       net-libs/gnutls
+       sys-libs/ncurses:0[unicode]
+       sys-libs/zlib
+       geoip? ( dev-libs/geoip )"
+DEPEND="${RDEPEND}
+       dev-util/makeheaders
+       virtual/pkgconfig"
+
+src_configure() {
+       econf \
+               $(use_with geoip)
+}
+
+src_compile() {
+       emake AR="$(tc-getAR)"
+}
index 9994fd80c8f239eff4e73c2244eaaaf79fe2dc1a..b140e9e32b3a2bc36c473050b51bccf5a9a06339 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-inherit autotools eutils git-2 toolchain-funcs
+inherit autotools git-r3 toolchain-funcs
 
 DESCRIPTION="ncurses directconnect client"
 HOMEPAGE="http://dev.yorhel.nl/ncdc"
@@ -26,13 +26,13 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 src_prepare() {
-       epatch_user
+       default
        eautoreconf
 }
 
 src_configure() {
        econf --enable-git-version \
-                $(use_with geoip)
+               $(use_with geoip)
 }
 
 src_compile() {