media-libs/gst-plugins-good: Fix for >=make-4.3
authorDavid Seifert <soap@gentoo.org>
Wed, 18 Mar 2020 11:22:19 +0000 (12:22 +0100)
committerDavid Seifert <soap@gentoo.org>
Wed, 18 Mar 2020 11:22:19 +0000 (12:22 +0100)
Closes: https://bugs.gentoo.org/705974
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/gst-plugins-good/files/gst-plugins-good-1.14.5-make43.patch [new file with mode: 0644]
media-libs/gst-plugins-good/gst-plugins-good-1.14.5.ebuild

diff --git a/media-libs/gst-plugins-good/files/gst-plugins-good-1.14.5-make43.patch b/media-libs/gst-plugins-good/files/gst-plugins-good-1.14.5-make43.patch
new file mode 100644 (file)
index 0000000..2429bf2
--- /dev/null
@@ -0,0 +1,56 @@
+--- a/common/glib-gen.mak
++++ b/common/glib-gen.mak
+@@ -1,11 +1,13 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_enum_prefix=gst_color_balance
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ # these are all the rules generating the relevant files
+ %-marshal.h: %-marshal.list
+--- a/common/gst-glib-gen.mak
++++ b/common/gst-glib-gen.mak
+@@ -1,13 +1,15 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+ #glib_gen_decl_banner=GST_EXPORT
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ # these are all the rules generating the relevant files
+ $(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
+--- a/sys/v4l2/Makefile.in
++++ b/sys/v4l2/Makefile.in
+@@ -17,6 +17,8 @@
+ # these are the variables your Makefile.am should set
+ # the example is based on the colorbalance interface
++H := \#
++
+ #glib_enum_headers=$(colorbalance_headers)
+ #glib_enum_define=GST_COLOR_BALANCE
+ #glib_gen_prefix=gst_color_balance
+@@ -669,7 +671,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ plugin_LTLIBRARIES = libgstvideo4linux2.la
+-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
+ libgstvideo4linux2_la_SOURCES = gstv4l2.c \
+                               gstv4l2allocator.c \
+                               gstv4l2colorbalance.c \
index 112f1972ea157d422de3cff0d1df90a7727489d5..94dfa129e9de8a83a27c114b223f7cdaf11fa407 100644 (file)
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
        >=dev-util/gtk-doc-am-1.12
 "
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.14.5-make43.patch # remove when bumping and switching to Meson
+)
+
 multilib_src_configure() {
        # Always enable optional bz2 support for matroska
        # Always enable optional zlib support for qtdemux and matroska