media-libs/gst-plugins-bad: drop now unnecessary IUSE="egl gles2 opengl"
authorMart Raudsepp <leio@gentoo.org>
Sun, 3 May 2020 15:02:55 +0000 (18:02 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 3 May 2020 19:11:52 +0000 (22:11 +0300)
All the remaining opengl plugin components (mixers) got moved into
gst-plugins-base too with 1.16, and IUSE=egl was already only
transitional in 1.14, and isn't used by anything anymore, so can
go away as well.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-libs/gst-plugins-bad/gst-plugins-bad-1.16.2.ebuild

index 04cddb677569496ef0f4e7bff2771cffe3cbd9e2..168be0bfd904357facdec16a6cca93def58bc3e6 100644 (file)
@@ -12,15 +12,13 @@ HOMEPAGE="https://gstreamer.freedesktop.org/"
 LICENSE="LGPL-2"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
 
-# TODO: egl IUSE only for transition
-IUSE="X bzip2 +egl gles2 +introspection +opengl +orc vnc wayland" # Keep default IUSE mirrored with gst-plugins-base where relevant
+IUSE="X bzip2 +introspection +orc vnc wayland"
 
 # X11 is automagic for now, upstream #709530 - only used by librfb USE=vnc plugin
-# We mirror opengl/gles2 from -base to ensure no automagic openglmixers plugin (with "opengl?" it'd still get built with USE=-opengl here)
 RDEPEND="
        >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
        >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
-       >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl?,introspection?,gles2=,opengl=]
+       >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
        introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
 
        bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
@@ -51,13 +49,6 @@ src_prepare() {
 }
 
 multilib_src_configure() {
-       local myconf=()
-       if use opengl || use gles2; then
-               myconf+=( --enable-gl )
-       else
-               myconf+=( --disable-gl )
-       fi
-
        # Always enable shm (shm_open) and ipcpipeline (sys/socket.h); no extra deps
        gstreamer_multilib_src_configure \
                $(multilib_native_use_enable introspection) \
@@ -70,7 +61,7 @@ multilib_src_configure() {
                --without-player-tests \
                --enable-shm \
                --enable-ipcpipeline \
-               "${myconf[@]}"
+               --disable-gl # eclass probably does this too, but be explicit as it used to be handled in ebuild here; all parts now in gst-plugins-base instead
 
        if multilib_is_native_abi; then
                local x