dev-python/pyzmq: Freshly cythonize source
authorJustin Lecher <jlec@gentoo.org>
Tue, 9 Feb 2016 13:15:31 +0000 (14:15 +0100)
committerJustin Lecher <jlec@gentoo.org>
Tue, 9 Feb 2016 14:31:20 +0000 (15:31 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pyzmq/pyzmq-15.2.0.ebuild

index 14689d380e2bf70f7a0859d1fc17dfcbd9c1ef15..ce4a92311743a2890774ae886415e62894c21110 100644 (file)
@@ -25,6 +25,7 @@ RDEPEND="
        dev-python/cffi:=[${PYTHON_USEDEP}]
        dev-python/gevent[${PY2_USEDEP}]"
 DEPEND="${RDEPEND}
+       dev-python/cython[${PYTHON_USEDEP}]
        test? ( dev-python/nose[${PYTHON_USEDEP}] )
        doc? (
                >=dev-python/sphinx-1.3[${PYTHON_USEDEP}]
@@ -46,6 +47,7 @@ python_compile_all() {
 }
 
 python_compile() {
+       esetup.py cython --force
        python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile
 }