www-client/firefox: check-reqs also in pkg_setup()
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 24 Feb 2020 22:27:24 +0000 (23:27 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 24 Feb 2020 22:35:17 +0000 (23:35 +0100)
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-68.5.0.ebuild
www-client/firefox/firefox-73.0.1.ebuild

index 811f352adb1304002fd4edc5e54caa0587d3fd51..55cb0402f54e58f8226d1cebfb990d6e40d5278d 100644 (file)
@@ -232,6 +232,15 @@ pkg_pretend() {
 pkg_setup() {
        moz_pkgsetup
 
+       # Ensure we have enough disk space to compile
+       if use pgo || use lto || use debug || use test ; then
+               CHECKREQS_DISK_BUILD="8G"
+       else
+               CHECKREQS_DISK_BUILD="4G"
+       fi
+
+       check-reqs_pkg_setup
+
        # Avoid PGO profiling problems due to enviroment leakage
        # These should *always* be cleaned up anyway
        unset DBUS_SESSION_BUS_ADDRESS \
index 6a7e5f80c0b4b69b7941a4124b7425a2cdd6e8a8..a9232b0afb238071d33447214779d63a85e158c8 100644 (file)
@@ -224,6 +224,15 @@ pkg_pretend() {
 pkg_setup() {
        moz_pkgsetup
 
+       # Ensure we have enough disk space to compile
+       if use pgo || use lto || use debug || use test ; then
+               CHECKREQS_DISK_BUILD="8G"
+       else
+               CHECKREQS_DISK_BUILD="4G"
+       fi
+
+       check-reqs_pkg_setup
+
        # Avoid PGO profiling problems due to enviroment leakage
        # These should *always* be cleaned up anyway
        unset DBUS_SESSION_BUS_ADDRESS \