app-admin/salt-3000.2-r3: revbump,pycrypto deps, fix warning (bug #720148)
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 30 Apr 2020 18:56:47 +0000 (11:56 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 30 Apr 2020 18:57:38 +0000 (11:57 -0700)
Get rid of all pycrypto deps from requirements files, fix
collections.abc warning in bundled tornado.

Closes: https://bugs.gentoo.org/720148

Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-admin/salt/files/salt-3000.2-tornado-py38.patch [new file with mode: 0644]
app-admin/salt/salt-3000.2-r3.ebuild [moved from app-admin/salt/salt-3000.2-r2.ebuild with 96% similarity]

diff --git a/app-admin/salt/files/salt-3000.2-tornado-py38.patch b/app-admin/salt/files/salt-3000.2-tornado-py38.patch
new file mode 100644 (file)
index 0000000..b324872
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ur salt-3000.2.orig/salt/ext/tornado/httputil.py salt-3000.2/salt/ext/tornado/httputil.py
+--- salt-3000.2.orig/salt/ext/tornado/httputil.py      2020-04-29 11:29:20.000000000 -0700
++++ salt-3000.2/salt/ext/tornado/httputil.py   2020-04-30 11:52:45.690890947 -0700
+@@ -104,7 +104,7 @@
+ _normalized_headers = _NormalizedHeaderCache(1000)
+-class HTTPHeaders(collections.MutableMapping):
++class HTTPHeaders(collections.abc.MutableMapping):
+     """A dictionary that maintains ``Http-Header-Case`` for all keys.
+     Supports multiple values per key via a pair of new methods,
similarity index 96%
rename from app-admin/salt/salt-3000.2-r2.ebuild
rename to app-admin/salt/salt-3000.2-r3.ebuild
index 2f37c30a24d48bfb4c2114533f0718f402f99c90..5e7ab8e084aa71135ee1beee52b8e7e5c76835a7 100644 (file)
@@ -111,6 +111,7 @@ PATCHES=(
 
        # https://github.com/saltstack/salt/pull/55900
        "${FILESDIR}/salt-3000.2-py38-abc.patch"
+       "${FILESDIR}/salt-3000.2-tornado-py38.patch"
 )
 
 python_prepare() {
@@ -122,6 +123,9 @@ python_prepare() {
        # tests that require network access
        rm tests/unit/{states,modules}/test_zcbuildout.py || die
 
+       # make sure pkg_resources doesn't bomb because pycrypto isn't installed
+       find . -name '*.txt' -print0 | xargs -0 sed -e '/pycrypto>/ d' -i || die
+
        # allow the use of the renamed msgpack
        sed -i '/^msgpack/d' requirements/base.txt || die
 }