net-vpn/openconnect: bump to 8.06
authorMike Gilbert <floppym@gentoo.org>
Thu, 2 Apr 2020 22:26:32 +0000 (18:26 -0400)
committerMike Gilbert <floppym@gentoo.org>
Thu, 2 Apr 2020 22:26:41 +0000 (18:26 -0400)
Package-Manager: Portage-2.3.96_p4, Repoman-2.3.22_p1
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
net-vpn/openconnect/Manifest
net-vpn/openconnect/openconnect-8.06.ebuild [new file with mode: 0644]

index 3eedcfb145b2b16d98889ce61277c0735e591590..c3eae30416fd814046efc7e1614d83924d35944e 100644 (file)
@@ -1,3 +1,4 @@
 DIST openconnect-8.05.tar.gz 1922100 BLAKE2B e12a5eccb471dc61c6f3af7492cb753fedcc52bfdb4155c934ca9c0c95da5e8037c0ede4f89345134fee8a09102f797690e101b8f4edba612ac265779feab19a SHA512 3ac9f1fa5a87b06d45c316897c69470264f2fde7525b5b3ef1352041dd0c8ae5eaf5dd325de1bdcf1e5b82e688fec9c36d531da1b75ac3f49896d4186d83aa15
+DIST openconnect-8.06.tar.gz 2030905 BLAKE2B d9659e4f027e11a0348c1c4358831e5f470f0305e04c22716010c68810ae300a7062ab8f57e3fc80b7d90caf855ce2f1c0af1b04eb7032b70486eee2eacc47e5 SHA512 6319aa6b20bf16994b376c2cc2a7cbf2b26a36f35e9607c1886e8fa7a2e1fe111bfb37f9349693ef52a3d2ce718c37e15fe263664e6c0bcbd33ced5ddb9e31b2
 DIST vpnc-scripts-20190611.tar.gz 21439 BLAKE2B 8388cc3f4b795588bed146cf5e6be33f20de010e39ddbc2bebea3680df9f304bc64db9d14c42cb0b0cb3c053376929476f4b52bf3c8da3fb4153d058eb6bab2b SHA512 91f84cf1881916160e26ec48195583ab79e084cc7b7918721581f25dfb5b1504e8073b0eed50c1a15800824d5a4454e9b99cb4fdffe2539e5968909fafdda87a
 DIST vpnc-scripts-20200226.tar.gz 21460 BLAKE2B 8f00ce3dc49725758abce27f3688946df1bbd4e92769ef02aa9ee66db8b9f41bef3442eaa5405ab1467476899c6d364dfea898ed924ca83497823a85515d48e5 SHA512 3a1eac4ccfaefb0f837189c8cef696b33ab8b8a68cb50a3ad29206b708d0aa479e8eed0c09bef6f60d056cd98d63cc898a1609d734030a63df3be2cfa6c00f9a
diff --git a/net-vpn/openconnect/openconnect-8.06.ebuild b/net-vpn/openconnect/openconnect-8.06.ebuild
new file mode 100644 (file)
index 0000000..95d40ab
--- /dev/null
@@ -0,0 +1,159 @@
+# Copyright 2011-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils linux-info python-any-r1 readme.gentoo-r1
+
+if [[ ${PV} == 9999 ]]; then
+       EGIT_REPO_URI="https://gitlab.com/openconnect/openconnect.git"
+       inherit git-r3 autotools
+else
+       ARCHIVE_URI="ftp://ftp.infradead.org/pub/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+VPNC_VER=20200226
+SRC_URI="${ARCHIVE_URI}
+       ftp://ftp.infradead.org/pub/vpnc-scripts/vpnc-scripts-${VPNC_VER}.tar.gz"
+
+DESCRIPTION="Free client for Cisco AnyConnect SSL VPN software"
+HOMEPAGE="http://www.infradead.org/openconnect.html"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0/5"
+IUSE="doc +gnutls gssapi libproxy libressl lz4 nls smartcard static-libs stoken"
+
+DEPEND="
+       dev-libs/libxml2
+       sys-libs/zlib
+       !gnutls? (
+               !libressl? ( >=dev-libs/openssl-1.0.1h:0=[static-libs?] )
+               libressl? ( dev-libs/libressl:0=[static-libs?] )
+       )
+       gnutls? (
+               app-crypt/trousers
+               app-misc/ca-certificates
+               dev-libs/nettle
+               >=net-libs/gnutls-3:0=[static-libs?]
+       )
+       gssapi? ( virtual/krb5 )
+       libproxy? ( net-libs/libproxy )
+       lz4? ( app-arch/lz4:= )
+       nls? ( virtual/libintl )
+       smartcard? ( sys-apps/pcsc-lite:0= )
+       stoken? ( app-crypt/stoken )"
+RDEPEND="${DEPEND}
+       sys-apps/iproute2
+       !<sys-apps/openrc-0.13"
+BDEPEND="
+       virtual/pkgconfig
+       doc? ( ${PYTHON_DEPS} sys-apps/groff )
+       nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="~TUN"
+
+pkg_pretend() {
+       check_extra_config
+}
+
+pkg_setup() {
+       :
+}
+
+src_unpack() {
+       if [[ ${PV} == 9999 ]]; then
+               git-r3_src_unpack
+       fi
+       default
+}
+
+src_prepare() {
+       default
+       if [[ ${PV} == 9999 ]]; then
+               eautoreconf
+       fi
+}
+
+src_configure() {
+       if use doc; then
+               python_setup
+       else
+               export ac_cv_path_PYTHON=
+       fi
+
+       # Used by tests if userpriv is disabled
+       addwrite /run/netns
+
+       local myconf=(
+               --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh"
+               $(use_enable static-libs static)
+               $(use_enable nls)
+               $(use_with !gnutls openssl)
+               $(use_with gnutls)
+               $(use_with libproxy)
+               $(use_with lz4)
+               $(use_with gssapi)
+               $(use_with smartcard libpcsclite)
+               $(use_with stoken)
+               --without-java
+       )
+
+       econf "${myconf[@]}"
+}
+
+DOC_CONTENTS="The init script for openconnect supports multiple vpn tunnels.
+
+You need to create a symbolic link to /etc/init.d/openconnect in /etc/init.d
+instead of calling it directly:
+
+ln -s /etc/init.d/openconnect /etc/init.d/openconnect.vpn0
+
+You can then start the vpn tunnel like this:
+
+/etc/init.d/openconnect.vpn0 start
+
+If you would like to run preup, postup, predown, and/or postdown scripts,
+You need to create a directory in /etc/openconnect with the name of the vpn:
+
+mkdir /etc/openconnect/vpn0
+
+Then add executable shell files:
+
+mkdir /etc/openconnect/vpn0
+cd /etc/openconnect/vpn0
+echo '#!/bin/sh' > preup.sh
+cp preup.sh predown.sh
+cp preup.sh postup.sh
+cp preup.sh postdown.sh
+chmod 755 /etc/openconnect/vpn0/*
+"
+
+src_install() {
+       default
+
+       newinitd "${FILESDIR}"/openconnect.init.in-r4 openconnect
+       dodir /etc/openconnect
+       insinto /etc/openconnect
+       newconfd "${FILESDIR}"/openconnect.conf.in openconnect
+       exeinto /etc/openconnect
+       newexe "${WORKDIR}"/vpnc-scripts-${VPNC_VER}/vpnc-script openconnect.sh
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/openconnect.logrotate openconnect
+       keepdir /var/log/openconnect
+
+       find "${ED}" -name '*.la' -delete || die
+
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               elog
+               elog "You may want to consider installing the following optional packages."
+               optfeature "resolvconf support" virtual/resolvconf
+       fi
+}