sci-libs/orocos_kdl: Install package.xml in our custom gentoo path from ebuild instea...
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 10:41:51 +0000 (11:41 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:26:50 +0000 (12:26 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-libs/orocos_kdl/files/gentoo.patch [deleted file]
sci-libs/orocos_kdl/orocos_kdl-1.3.1-r1.ebuild [moved from sci-libs/orocos_kdl/orocos_kdl-1.3.1.ebuild with 89% similarity]
sci-libs/orocos_kdl/orocos_kdl-9999.ebuild

diff --git a/sci-libs/orocos_kdl/files/gentoo.patch b/sci-libs/orocos_kdl/files/gentoo.patch
deleted file mode 100644 (file)
index 3766e12..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: orocos_kdl/CMakeLists.txt
-===================================================================
---- orocos_kdl.orig/CMakeLists.txt
-+++ orocos_kdl/CMakeLists.txt
-@@ -114,4 +114,4 @@ INSTALL(FILES ${PROJECT_BINARY_DIR}/oroc
- INSTALL(FILES ${PROJECT_BINARY_DIR}/orocos_kdl-config-version.cmake DESTINATION share/orocos_kdl)
- INSTALL(EXPORT OrocosKDLTargets DESTINATION share/orocos_kdl)
--INSTALL(FILES package.xml DESTINATION share/orocos_kdl)
-+INSTALL(FILES package.xml DESTINATION share/ros_packages/orocos_kdl)
similarity index 89%
rename from sci-libs/orocos_kdl/orocos_kdl-1.3.1.ebuild
rename to sci-libs/orocos_kdl/orocos_kdl-1.3.1-r1.ebuild
index fac689144b5700c2ba27810d1ab8d78b14c987bf..8207c1ea2f3c6a2654894c78d172c80aa44671aa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -33,7 +33,6 @@ DEPEND="${RDEPEND}
 REQUIRED_USE="examples? ( models )"
 
 DOCS=( README )
-PATCHES=( "${FILESDIR}/gentoo.patch" )
 
 if [ "${PV#9999}" != "${PV}" ] ; then
        S=${WORKDIR}/${P}/orocos_kdl
@@ -66,4 +65,8 @@ src_install() {
        cd "${BUILD_DIR}"
        use doc && dohtml -r doc/api/html/*
        use examples && dobin "${BUILD_DIR}/examples/"{geometry,trajectory_example,chainiksolverpos_lma_demo}
+
+       # Need to have package.xml in our custom gentoo path
+       insinto /usr/share/ros_packages/${PN}
+       doins "${ED}/usr/share/${PN}/package.xml"
 }
index fac689144b5700c2ba27810d1ab8d78b14c987bf..8207c1ea2f3c6a2654894c78d172c80aa44671aa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -33,7 +33,6 @@ DEPEND="${RDEPEND}
 REQUIRED_USE="examples? ( models )"
 
 DOCS=( README )
-PATCHES=( "${FILESDIR}/gentoo.patch" )
 
 if [ "${PV#9999}" != "${PV}" ] ; then
        S=${WORKDIR}/${P}/orocos_kdl
@@ -66,4 +65,8 @@ src_install() {
        cd "${BUILD_DIR}"
        use doc && dohtml -r doc/api/html/*
        use examples && dobin "${BUILD_DIR}/examples/"{geometry,trajectory_example,chainiksolverpos_lma_demo}
+
+       # Need to have package.xml in our custom gentoo path
+       insinto /usr/share/ros_packages/${PN}
+       doins "${ED}/usr/share/${PN}/package.xml"
 }