dev-libs/yaz: bump EAPI and add libressl support
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 26 Jun 2016 12:08:19 +0000 (08:08 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 26 Jun 2016 12:24:38 +0000 (08:24 -0400)
Package-Manager: portage-2.2.28

dev-libs/yaz/yaz-3.0.53.ebuild
dev-libs/yaz/yaz-4.2.30.ebuild
dev-libs/yaz/yaz-4.2.51.ebuild

index 9fdd73c018901105cf42796fdc96660a1a3e269d..6d3e25304ff3c4d9045cd2a1ca0083e6222f1438 100644 (file)
@@ -1,22 +1,23 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=2
+EAPI=5
 inherit eutils autotools
 
-DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+DESCRIPTION="C/C++ toolkit for Z39.50v3 clients and servers"
 HOMEPAGE="http://www.indexdata.dk/yaz"
 SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
 
 LICENSE="BSD GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="debug icu tcpd ziffy"
+IUSE="debug icu libressl tcpd ziffy"
 
 RDEPEND="dev-libs/libxml2
        dev-libs/libxslt
-       dev-libs/openssl
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
        icu? ( dev-libs/icu )
        tcpd? ( sys-apps/tcp-wrappers )
        ziffy? ( net-libs/libpcap )"
index a2a7d782a9d15b370e296d8fcd02a6720360e113..874523278c8ea0ea80ef6de00e5b96b4365c990c 100644 (file)
@@ -1,22 +1,23 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=2
+EAPI=5
 inherit eutils autotools
 
-DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+DESCRIPTION="C/C++ toolkit for Z39.50v3 clients and servers"
 HOMEPAGE="http://www.indexdata.dk/yaz"
 SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
 
 LICENSE="BSD GPL-2"
 SLOT="4"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="debug icu tcpd ziffy"
+IUSE="debug icu libressl tcpd ziffy"
 
 RDEPEND="dev-libs/libxml2
        dev-libs/libxslt
-       dev-libs/openssl
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
        icu? ( dev-libs/icu )
        tcpd? ( sys-apps/tcp-wrappers )
        ziffy? ( net-libs/libpcap )"
index a2a7d782a9d15b370e296d8fcd02a6720360e113..874523278c8ea0ea80ef6de00e5b96b4365c990c 100644 (file)
@@ -1,22 +1,23 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=2
+EAPI=5
 inherit eutils autotools
 
-DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+DESCRIPTION="C/C++ toolkit for Z39.50v3 clients and servers"
 HOMEPAGE="http://www.indexdata.dk/yaz"
 SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
 
 LICENSE="BSD GPL-2"
 SLOT="4"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="debug icu tcpd ziffy"
+IUSE="debug icu libressl tcpd ziffy"
 
 RDEPEND="dev-libs/libxml2
        dev-libs/libxslt
-       dev-libs/openssl
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
        icu? ( dev-libs/icu )
        tcpd? ( sys-apps/tcp-wrappers )
        ziffy? ( net-libs/libpcap )"