dev-vcs/mercurial: Version bumps
authorCédric Krier <cedk@gentoo.org>
Sat, 14 Mar 2020 11:57:35 +0000 (12:57 +0100)
committerCédric Krier <cedk@gentoo.org>
Mon, 16 Mar 2020 11:03:13 +0000 (12:03 +0100)
Closes: https://bugs.gentoo.org/712188
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Cédric Krier <cedk@gentoo.org>
dev-vcs/mercurial/Manifest
dev-vcs/mercurial/mercurial-5.3.1.ebuild [new file with mode: 0644]
dev-vcs/mercurial/mercurial-9999.ebuild

index c4c2fbabd1a360248a00a151e415ba3be3b97c5c..39563ed60705c5e72b7d66c29bd5f51c467fd72f 100644 (file)
@@ -4,3 +4,4 @@ DIST mercurial-4.9.tar.gz 7075692 BLAKE2B ed11442e0cd5b27f47394ed1c15016930556d5
 DIST mercurial-5.0.2.tar.gz 7202797 BLAKE2B 7059efa2cf80c433ec25748c7c49ae0caa688363f5ef2983e0adf39a0a691ea99aaf4a090ebeda11b89e74263c548289cca3f82f40d77efbf925e12231b341cc SHA512 8b328e2e5a2896b690492d75c055bb13cd76df6efb087ef770f60ead86e30f7d952cb3ca82a696c0c5ce7039c319bd0fc9b448a52c079653622760317d5bb315
 DIST mercurial-5.1.2.tar.gz 7286238 BLAKE2B 0dcb2556e568e222da628bcfeceba56df8ab04f123f79add1953ce13bbf51e5cb0733fa72d5cff00250aaf0e3bfae5c52cc5cd72c1b6aa1fccb6820fce5a7018 SHA512 a8ce9d9220a5ddf452264801f06e81fe1e699ff700d085e3f82c6877910c6ef0e594203590f198b7b9e31c9a1ed627c8fa2a3a1513d0c5087cf775835a78c408
 DIST mercurial-5.2.2.tar.gz 7333065 BLAKE2B 9cec5a6ebe4693a1b96fe268211aa2eaa06643d5b8812c427757839d5389319f0e2ff3c1ed964a56bf8a3c46f7630321abf508c61691102856dfbdbd72fed662 SHA512 875e75587ab1f1c54edd2f7198dff21e6b287425f215a9d28ef98d5359420df90ca7ef0128ec7b772c4a31dc95b1082b4d6d28f1754968a08408516ba9ec91ee
+DIST mercurial-5.3.1.tar.gz 7511733 BLAKE2B 713074092d29ee7e35dbed73e38e120d802477b55fcab7c497cf78a1c4b00fc5aaf9ab323c64d58660c39454b4d6d0d130a620b7afc08141b9a2016052f3a3b9 SHA512 3bc49ea96cb4ac0e777f667a3243917af495a001534b6b91141fc93b5c47a8eddc84331e1cb0b981fac1bf451dcfc91b8c538134983733466248fdc20afd39c6
diff --git a/dev-vcs/mercurial/mercurial-5.3.1.ebuild b/dev-vcs/mercurial/mercurial-5.3.1.ebuild
new file mode 100644 (file)
index 0000000..e0eb454
--- /dev/null
@@ -0,0 +1,171 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6..8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="https://www.mercurial-scm.org/"
+SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+chg emacs gpg test tk zsh-completion"
+
+BROKEN_PYTHON="
+       !~dev-python/python-3.5.0
+       !~dev-python/python-3.5.1
+       !~dev-python/python-3.5.2
+       !~dev-python/python-3.6.0
+       !~dev-python/python-3.6.1"
+
+BDEPEND="${BROKEN_PYTHON}"
+
+RDEPEND="${BROKEN_PYTHON}
+       app-misc/ca-certificates
+       dev-python/zstandard[${PYTHON_USEDEP}]
+       gpg? ( app-crypt/gnupg )
+       tk? ( dev-lang/tk )
+       zsh-completion? ( app-shells/zsh )"
+
+DEPEND="emacs? ( >=app-editors/emacs-23.1:* )
+       test? ( app-arch/unzip
+               dev-python/pygments[${PYTHON_USEDEP}] )"
+
+SITEFILE="70${PN}-gentoo.el"
+
+# Too many tests fail #608720
+RESTRICT="test"
+
+python_prepare_all() {
+       # fix up logic that won't work in Gentoo Prefix (also won't outside in
+       # certain cases), bug #362891
+       sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+       # Use absolute import for zstd
+       sed -i -e 's/from \.* import zstd/import zstd/' \
+               mercurial/utils/compression.py \
+               mercurial/wireprotoframing.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile() {
+       filter-flags -ftracer -ftree-vectorize
+       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+       distutils-r1_python_compile build_ext --no-zstd
+}
+
+python_compile_all() {
+       rm -r contrib/win32 || die
+       if use chg; then
+               emake -C contrib/chg
+       fi
+       if use emacs; then
+               cd contrib || die
+               elisp-compile mercurial.el || die "elisp-compile failed!"
+       fi
+}
+
+python_install() {
+       distutils-r1_python_install build_ext --no-zstd
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       newbashcomp contrib/bash_completion hg
+
+       if use zsh-completion ; then
+               insinto /usr/share/zsh/site-functions
+               newins contrib/zsh_completion _hg
+       fi
+
+       dobin hgeditor
+       if use tk; then
+               dobin contrib/hgk
+       fi
+       python_foreach_impl python_doscript contrib/hg-ssh
+
+       if use emacs; then
+               elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+               elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+       fi
+
+       local RM_CONTRIB=( hgk hg-ssh bash_completion zsh_completion plan9 *.el )
+
+       if use chg; then
+               dobin contrib/chg/chg
+               doman contrib/chg/chg.1
+               RM_CONTRIB+=( chg )
+       fi
+
+       for f in ${RM_CONTRIB[@]}; do
+               rm -rf contrib/${f} || die
+       done
+
+       dodoc -r contrib
+       docompress -x /usr/share/doc/${PF}/contrib
+       doman doc/*.?
+       dodoc CONTRIBUTORS hgweb.cgi
+
+       insinto /etc/mercurial/hgrc.d
+       doins "${FILESDIR}/cacerts.rc"
+}
+
+src_test() {
+       pushd tests &>/dev/null || die
+       rm -rf *svn*                    # Subversion tests fail with 1.5
+       rm -f test-archive*             # Fails due to verbose tar output changes
+       rm -f test-convert-baz*         # GNU Arch baz
+       rm -f test-convert-cvs*         # CVS
+       rm -f test-convert-darcs*       # Darcs
+       rm -f test-convert-git*         # git
+       rm -f test-convert-mtn*         # monotone
+       rm -f test-convert-tla*         # GNU Arch tla
+       rm -f test-largefiles*          # tends to time out
+       if [[ ${EUID} -eq 0 ]]; then
+               einfo "Removing tests which require user privileges to succeed"
+               rm -f test-convert*
+               rm -f test-lock-badness*
+               rm -f test-permissions*
+               rm -f test-pull-permission*
+               rm -f test-journal-exists*
+               rm -f test-repair-strip*
+       fi
+
+       popd &>/dev/null || die
+       distutils-r1_src_test
+}
+
+python_test() {
+       local TEST_DIR
+
+       rm -rf "${TMPDIR}"/test
+       distutils_install_for_testing
+       cd tests || die
+       "${PYTHON}" run-tests.py --verbose \
+               --tmpdir="${TMPDIR}"/test \
+               --with-hg="${TEST_DIR}"/scripts/hg \
+               || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+
+       elog "If you want to convert repositories from other tools using convert"
+       elog "extension please install correct tool:"
+       elog "  dev-vcs/cvs"
+       elog "  dev-vcs/darcs"
+       elog "  dev-vcs/git"
+       elog "  dev-vcs/monotone"
+       elog "  dev-vcs/subversion"
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}
index 8a93eddd65bfa934a627b3c0bf772bdbbc6bbaf6..6a75f6d2818d5b72f9043c3d6ec230e47ac1cf27 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6..7} )
+PYTHON_COMPAT=( python2_7 python3_{6..8} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit bash-completion-r1 elisp-common eutils distutils-r1 mercurial flag-o-matic
@@ -15,7 +15,7 @@ EHG_REPO_URI="https://www.mercurial-scm.org/repo/hg"
 LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS=""
-IUSE="+chg bugzilla emacs gpg test tk zsh-completion"
+IUSE="+chg emacs gpg test tk zsh-completion"
 
 BROKEN_PYTHON="
        !~dev-python/python-3.5.0