media-gfx/graphviz: version bump to 2.42.1
authorChris Mayo <aklhfex@gmail.com>
Sun, 25 Aug 2019 18:56:52 +0000 (19:56 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 14 Sep 2019 14:52:24 +0000 (16:52 +0200)
Bug: https://bugs.gentoo.org/682522
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Chris Mayo <aklhfex@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12790
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/graphviz/Manifest
media-gfx/graphviz/files/graphviz-2.42.1-libgv_python.patch [new file with mode: 0644]
media-gfx/graphviz/files/graphviz-2.42.1-math.patch [new file with mode: 0644]
media-gfx/graphviz/graphviz-2.42.1.ebuild [new file with mode: 0644]

index b2df6ab0c2f9f297d6de3c656764801cff920826..5159a80cab1fa49c3a14215ece950588db253c3d 100644 (file)
@@ -1 +1,2 @@
 DIST graphviz-2.40.1.tar.gz 25633455 BLAKE2B 96ba5a8cb94d93cf4ecd424bf29c1bf67099e39e582be97fca088de0aad6bbbb46b00af55c197894e0b63f1a96177894b6cd23498295bb524fe19a75661cbc59 SHA512 a3f358a7050523a39b91a259563a95925b37853ffec799e571211af5b686d3af42457c937882954482785745d90416b1abd945caf05f8abb52b3876e07aa70f5
+DIST graphviz-2.42.1.tar.gz 25543401 BLAKE2B e64044923a823f6fbe91b498b04fffe3e5b6803c55c5ce29a60b16a38d97260061b013e8bd13bc99f360d035c840f18a01301b29ca1cb73c4be87843f18c45fc SHA512 ac263df086eea6faf682f493756b79a0af8bae3f515cd8c09238e89f295226baf743a3fd22d977ef6f223388769ef11241dfb2fdb6087305ce4fdd3fa8ed2f78
diff --git a/media-gfx/graphviz/files/graphviz-2.42.1-libgv_python.patch b/media-gfx/graphviz/files/graphviz-2.42.1-libgv_python.patch
new file mode 100644 (file)
index 0000000..426ebbe
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/tclpkg/gv/Makefile.am
++++ b/tclpkg/gv/Makefile.am
+@@ -430,10 +430,10 @@
+       (cd $(DESTDIR)$(pkgpythondir); rm -f _gv.so; $(LN_S) libgv_python.so _gv.so;)
+ endif
+ if WITH_PYTHON2
+-      (cd $(DESTDIR)$(pkgpython2dir); rm -f _gv.so; $(LN_S) libgv_python.so _gv.so;)
++      (cd $(DESTDIR)$(pkgpython2dir); rm -f _gv.so; $(LN_S) libgv_python2.so _gv.so;)
+ endif
+ if WITH_PYTHON3
+-      (cd $(DESTDIR)$(pkgpython3dir); rm -f _gv.so; $(LN_S) libgv_python.so _gv.so;)
++      (cd $(DESTDIR)$(pkgpython3dir); rm -f _gv.so; $(LN_S) libgv_python3.so _gv.so;)
+ endif
+ if WITH_R
+       (cd $(DESTDIR)$(pkgRdir);   rm -f gv.so;  $(LN_S) libgv_R.so gv.so;)
diff --git a/media-gfx/graphviz/files/graphviz-2.42.1-math.patch b/media-gfx/graphviz/files/graphviz-2.42.1-math.patch
new file mode 100644 (file)
index 0000000..59b8481
--- /dev/null
@@ -0,0 +1,38 @@
+diff --git a/lib/sfio/sfdlen.c b/lib/sfio/sfdlen.c
+index 2b4f8b0a3..3b2c75066 100644
+--- a/lib/sfio/sfdlen.c
++++ b/lib/sfio/sfdlen.c
+@@ -13,6 +13,8 @@
+ #include      "sfhdr.h"
++#include <math.h>
++
+ /*    Return the length of a double value if coded in a portable format
+ **
+ **    Written by Kiem-Phong Vo
+diff --git a/lib/sfio/sfgetd.c b/lib/sfio/sfgetd.c
+index 535b2cb9a..607681e60 100644
+--- a/lib/sfio/sfgetd.c
++++ b/lib/sfio/sfgetd.c
+@@ -13,6 +13,8 @@
+ #include      "sfhdr.h"
++#include <math.h>
++
+ /*    Read a portably coded double value
+ **
+ **    Written by Kiem-Phong Vo
+diff --git a/lib/sfio/sfputd.c b/lib/sfio/sfputd.c
+index 64ab9eaf3..a2dbd225c 100644
+--- a/lib/sfio/sfputd.c
++++ b/lib/sfio/sfputd.c
+@@ -14,6 +14,7 @@
+ #include      "sfhdr.h"
+ #include <float.h>
++#include <math.h>
+ /*    Write out a floating point value in a portable format
+ **
diff --git a/media-gfx/graphviz/graphviz-2.42.1.ebuild b/media-gfx/graphviz/graphviz-2.42.1.ebuild
new file mode 100644 (file)
index 0000000..b901f7c
--- /dev/null
@@ -0,0 +1,283 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit autotools flag-o-matic java-pkg-opt-2 python-single-r1 qmake-utils
+
+DESCRIPTION="Open Source Graph Visualization Software"
+HOMEPAGE="https://www.graphviz.org/ https://gitlab.com/graphviz/graphviz/"
+SRC_URI="https://www2.graphviz.org/Packages/stable/portable_source/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="+cairo devil doc examples gdk-pixbuf gtk gts guile java lasi nls pdf perl postscript python qt5 ruby static-libs svg tcl X elibc_FreeBSD"
+
+REQUIRED_USE="
+       !cairo? ( !X !gtk !postscript !lasi )
+       python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Requires ksh, tests against installed package, missing files and directory
+RESTRICT="test"
+
+COMMON_DEPEND="
+       >=dev-libs/expat-2
+       >=dev-libs/glib-2.11.1:2
+       dev-libs/libltdl:0
+       >=media-libs/fontconfig-2.3.95
+       >=media-libs/freetype-2.1.10
+       >=media-libs/gd-2.0.34:=[fontconfig,jpeg,png,truetype,zlib]
+       >=media-libs/libpng-1.2:0
+       sys-libs/zlib
+       virtual/jpeg:0
+       virtual/libiconv
+       cairo?  (
+               >=x11-libs/cairo-1.1.10[svg]
+               >=x11-libs/pango-1.12
+       )
+       devil?  ( media-libs/devil[png,jpeg] )
+       gtk?    ( x11-libs/gtk+:2 )
+       gts?    ( sci-libs/gts )
+       lasi?   ( media-libs/lasi )
+       pdf?    ( app-text/poppler )
+       perl?   ( dev-lang/perl:= )
+       postscript? ( app-text/ghostscript-gpl )
+       python? ( ${PYTHON_DEPS} )
+       qt5?    (
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtwidgets:5
+       )
+       ruby?   ( dev-lang/ruby:* )
+       svg?    ( gnome-base/librsvg )
+       tcl?    ( >=dev-lang/tcl-8.3:0= )
+       X? (
+               x11-libs/libX11
+               x11-libs/libXaw
+               x11-libs/libXmu
+               x11-libs/libXpm
+               x11-libs/libXt
+       )"
+DEPEND="${COMMON_DEPEND}
+       sys-devel/flex
+       sys-devel/libtool
+       virtual/pkgconfig
+       guile?  ( dev-lang/swig dev-scheme/guile )
+       java?   ( dev-lang/swig >=virtual/jdk-1.5 )
+       nls?    ( >=sys-devel/gettext-0.14.5 )
+       perl?   ( dev-lang/swig )
+       python? ( dev-lang/swig )
+       ruby?   ( dev-lang/swig )
+       tcl?    ( dev-lang/swig )"
+RDEPEND="${COMMON_DEPEND}
+       !<=sci-chemistry/cluster-1.3.081231"
+
+# Dependency description / Maintainer-Info:
+
+# Rendering is done via the following plugins (/plugins):
+# - core, dot_layout, neato_layout, gd , dot
+#   the ones which are always compiled in, depend on zlib, gd
+# - gtk
+#   Directly depends on gtk-2.
+#   needs 'pangocairo' enabled in graphviz configuration
+#   gtk-2 depends on pango, cairo and libX11 directly.
+# - gdk-pixbuf
+#   Disabled, GTK-1 junk.
+# - glitz
+#   Disabled, no particular reason
+#   needs 'pangocairo' enabled in graphviz configuration
+# - ming
+#   flash plugin via -Tswf requires media-libs/ming-0.4. Disabled as it's
+#   incomplete.
+# - cairo/pango:
+#   Needs pango for text layout, uses cairo methods to draw stuff
+# - xlib:
+#   needs cairo+pango,
+#   can make use of gnomeui and inotify support (??? unsure),
+#   needs libXaw for UI
+#   UI also links directly against libX11, libXmu, and libXt
+#   and uses libXpm if available so we make sure it always is
+
+# There can be swig-generated bindings for the following languages (/tclpkg/gv):
+# - c-sharp (disabled)
+# - scheme (enabled via guile) ... no longer broken on ~x86
+# - io (disabled)
+# - java (enabled via java) *2
+# - lua (enabled via lua)
+# - ocaml (enabled via ocaml)
+# - perl (enabled via perl) *1
+# - php (enabled via php) *2
+# - python (enabled via python) *1
+# - ruby (enabled via ruby) *1
+# - tcl (enabled via tcl)
+# *1 = The ${P}-bindings.patch takes care that those bindings are installed to the right location
+# *2 = Those bindings don't build because the paths for the headers/libs aren't
+#      detected correctly and/or the options passed to swig are wrong (-php instead of -php4/5)
+
+# There are several other tools in /tclpkg:
+# gdtclft, tcldot, tclhandle, tclpathplan, tclstubs ; enabled with: --with-tcl
+# tkspline, tkstubs ; enabled with: --with-tk
+
+# And the commands (/cmd):
+# - dot, dotty, gvedit, gvpr, lefty, lneato, smyrna, tools/* :)
+#   sci-libs/gts can be used for some of these
+# - lefty:
+#   needs Xaw and X to build
+# - gvedit (via 'qt5'):
+#   based on ./configure it needs qt-core and qt-gui only
+# - smyrna : experimental opengl front-end (via 'smyrna')
+#   currently disabled -- it segfaults a lot
+#   needs x11-libs/gtkglext, gnome-base/libglade, media-libs/freeglut
+#   sci-libs/gts, x11-libs/gtk.  Also needs 'gtk','glade','glut','gts' and 'png'
+#   with flags enabled at configure time
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.34.0-Xaw-configure.patch
+       "${FILESDIR}"/${P}-libgv_python.patch
+       "${FILESDIR}"/${P}-math.patch
+)
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+
+       java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # ToDo: Do the same thing for examples and/or
+       #       write a patch for a configuration-option
+       #       and send it to upstream
+       # note - the longer sed expression removes multi-line assignments that are extended via '\'
+       if ! use doc ; then
+               find . -iname Makefile.am \
+                       | xargs sed -i -e '/^\(html\|pdf\)_DATA.*\\[[:space:]]*$/{:m;N;s/\\\n//;tm;d}' \
+                               -e '/^\(html\|pdf\)_DATA/d' || die
+       fi
+
+       # This is an old version of libtool
+       # use the ./configure option to exclude its use, and
+       # delete the dir since we don't need to eautoreconf it
+       rm -r libltdl || die
+
+       # Nuke the dead symlinks for the bindings
+       sed -i -e '/$(pkgluadir)/d' tclpkg/gv/Makefile.am || die
+
+       # replace the whitespace with tabs
+       sed -i -e 's:  :\t:g' doc/info/Makefile.am || die
+
+       # use correct version of qmake. bug #567236
+       sed -i -e "/AC_CHECK_PROGS(QMAKE/a AC_SUBST(QMAKE,$(qt5_get_bindir)/qmake)" configure.ac || die
+
+       # workaround for http://www.graphviz.org/mantisbt/view.php?id=1895
+       use elibc_FreeBSD && append-flags $(test-flags -fno-builtin-sincos)
+
+       use java && append-cppflags $(java-pkg_get-jni-cflags)
+
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=(
+               --enable-ltdl
+               --disable-silent-rules
+               $(use_enable static-libs static)
+       )
+
+       # libtool file collision, bug 276609
+       myconf+=( --without-included-ltdl --disable-ltdl-install )
+
+       myconf+=(
+               $(use_with cairo pangocairo)
+               $(use_with devil)
+               $(use_with gtk)
+               $(use_with gts)
+               $(use_with qt5 qt)
+               $(use_with lasi)
+               $(use_with pdf poppler)
+               $(use_with postscript ghostscript)
+               $(use_with svg rsvg)
+               $(use_with X x)
+               $(use_with X xaw)
+               $(use_with X lefty)
+               --with-digcola
+               --with-fontconfig
+               --with-freetype2
+               --with-ipsepcola
+               --with-libgd
+               --with-sfdp
+               $(use_enable gdk-pixbuf)
+               --without-ming
+       )
+
+       # new/experimental features, to be tested, disable for now
+       myconf+=(
+               --with-cgraph
+               --without-glitz
+               --without-ipsepcola
+               --without-smyrna
+               --without-visio
+       )
+
+       # Bindings:
+       myconf+=(
+               $(use_enable guile)
+               --disable-io
+               $(use_enable java)
+               --disable-lua
+               --disable-ocaml
+               $(use_enable perl)
+               --disable-php
+               --disable-python
+               $(use_enable python python2)
+               $(use_enable python python3)
+               --disable-r
+               $(use_enable ruby)
+               --disable-sharp
+               $(use_enable tcl)
+       )
+
+       econf ${myconf[@]}
+}
+
+src_install() {
+       sed -i -e "s:htmldir:htmlinfodir:g" doc/info/Makefile || die
+
+       emake DESTDIR="${D}" \
+               txtdir="${EPREFIX}"/usr/share/doc/${PF} \
+               htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+               htmlinfodir="${EPREFIX}"/usr/share/doc/${PF}/html/info \
+               pdfdir="${EPREFIX}"/usr/share/doc/${PF}/pdf \
+               pkgconfigdir="${EPREFIX}"/usr/$(get_libdir)/pkgconfig \
+               install
+
+       if ! use examples; then
+               rm -rf "${ED}"/usr/share/graphviz/demo || die
+       fi
+
+       if ! use static-libs; then
+               find "${ED}" -name '*.la' -delete || die
+       fi
+
+       dodoc AUTHORS ChangeLog NEWS README
+
+       use python && python_optimize \
+               "${D}$(python_get_sitedir)" \
+               "${D}/usr/$(get_libdir)/graphviz/python2" \
+               "${D}/usr/$(get_libdir)/graphviz/python3"
+}
+
+pkg_postinst() {
+       # This actually works if --enable-ltdl is passed
+       # to configure
+       dot -c || die
+}
+
+pkg_postrm() {
+       # Remove cruft, bug #547344
+       rm -rf "${EROOT}"usr/$(get_libdir)/graphviz/config{,6} || die
+}