sci-mathematics/z3: Bump to 4.8.6
authorMichał Górny <mgorny@gentoo.org>
Fri, 20 Sep 2019 06:05:48 +0000 (08:05 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 20 Sep 2019 07:34:41 +0000 (09:34 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sci-mathematics/z3/Manifest
sci-mathematics/z3/z3-4.8.6.ebuild [new file with mode: 0644]

index ff78e704a37b7c66b372c19f6d478c38647c91e5..d4bad76f6b661109e0e2dbf3493cb99317ea64aa 100644 (file)
@@ -1,3 +1,4 @@
 DIST Z3-4.8.5.tar.gz 4177051 BLAKE2B f8c4be9dbab2d5cf6fdb0bd8e9e1648f8ac29bc8ca9241b3ef29699400b383f09601149d50899d6ca828abadacb71161af1524df6d1ed45d7fd95c4a49c0d3df SHA512 ca36e1a0332bd473a64f41dfdb31656fb3486178473e4fd4934dccce109a84c9686c08f94998df74bacb588eb12ea5db25dc17a564ee76f82fd2559349697309
 DIST z3-4.4.1.tar.gz 3347371 BLAKE2B 57f090b891618613c4647a89620d12f2ac05ea110268e63b343594f53fa2cc7aa347781001e2778ea7dc1ce475c964ddeced7a82c304b4be706ad164fd17a285 SHA512 76991a24f47f2b53ceb8d7a9a6be19913c57994ffb6cf6acfe30f61b2e73959cf02a99f656053594fccb5aaf4d1f44b3ae7e51f1c8953b213d738ceeeaea74f8
 DIST z3-4.5.0.tar.gz 3573695 BLAKE2B 285cc4d1f998d61ddb0b854044b7c79c1bb4cccf51bbdcba7c4a45698d74d9591f84d0aa74c5ef7c8aea2c6539ac987f29e326b44037e954108df67644dff594 SHA512 1ebc2c908d90b6b879f1e819c864ff894613276af47a440f27cf94968c195656952434754c3eb20f4bdbdd8497d227d22e1b4821c0d320b11052b5648d9e2dc7
+DIST z3-4.8.6.tar.gz 4328752 BLAKE2B 4932670f3c1ab9bdba18a6ad80f4fd8812eb70d71705ebdf1f93c3b052ffb632dc10e4f7f4043f098af214288d6d4a4a26ef7f8cc0d1183c9f27b14ef1787c46 SHA512 d338413274a3d11a9e9287202989df9da4c31e095c14428a418d4019e9f86c0e2b681c519d2d0bcbb4cd99a722a2539006f5c86ade568b1ee208545b142369f1
diff --git a/sci-mathematics/z3/z3-4.8.6.ebuild b/sci-mathematics/z3/z3-4.8.6.ebuild
new file mode 100644 (file)
index 0000000..67b683d
--- /dev/null
@@ -0,0 +1,93 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit cmake-multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       gmp? ( dev-libs/gmp:0=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+       doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+               -DUSE_LIB_GMP=$(usex gmp)
+               -DENABLE_EXAMPLE_TARGETS=OFF
+               -DBUILD_DOCUMENTATION=$(multilib_native_usex doc)
+               -DBUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+               -DBUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+       )
+
+       cmake-utils_src_configure
+}
+
+multilib_src_test() {
+       cmake-utils_src_make test-z3
+       set -- "${BUILD_DIR}"/test-z3 /a
+       echo "${@}" >&2
+       "${@}" || die
+}
+
+multilib_src_install_all() {
+       dodoc README.md RELEASE_NOTES
+       use examples && dodoc -r examples
+       use python && python_optimize
+
+       if use isabelle; then
+               insinto /usr/share/Isabelle/contrib/${P}/etc
+               newins - settings <<-EOF
+                       Z3_COMPONENT="\$COMPONENT"
+                       Z3_HOME="${EPREFIX}/usr/bin"
+                       Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+                       Z3_REMOTE_SOLVER="z3"
+                       Z3_VERSION="${PV}"
+                       Z3_INSTALLED="yes"
+                       Z3_NON_COMMERCIAL="yes"
+               EOF
+       fi
+}
+
+pkg_postinst() {
+       if use isabelle; then
+               if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+                       sed -e "/contrib\/${PN}-[0-9.]*/d" \
+                               -i "${ROOT}/etc/isabelle/components" || die
+                       cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+                               contrib/${P}
+                       EOF
+               fi
+       fi
+}
+
+pkg_postrm() {
+       if use isabelle; then
+               if [[ ! ${REPLACING_VERSIONS} ]]; then
+                       if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+                               # Note: this sed should only match the version of this ebuild
+                               # Which is what we want as we do not want to remove the line
+                               # of a new Isabelle component being installed during an upgrade.
+                               sed -e "/contrib\/${P}/d" \
+                                       -i "${ROOT}/etc/isabelle/components" || die
+                       fi
+               fi
+       fi
+}