dev-python/Numdifftools: Remove old
authorDavid Seifert <soap@gentoo.org>
Thu, 26 Dec 2019 14:04:55 +0000 (15:04 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 26 Dec 2019 14:04:55 +0000 (15:04 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/Numdifftools/Manifest
dev-python/Numdifftools/Numdifftools-0.9.12.ebuild [deleted file]
dev-python/Numdifftools/Numdifftools-0.9.13.ebuild [deleted file]
dev-python/Numdifftools/Numdifftools-0.9.14.ebuild [deleted file]

index c738e07987a436fc7369e0c1a5afa4dd883fe6ed..8e61b06d1ebad754a823ebb5864ae8744d1e4e67 100644 (file)
@@ -1,4 +1 @@
-DIST numdifftools-0.9.12.zip 236823 BLAKE2B e555ee2f02b071c664f2761c79f0b90526c7b56b66d10f3b449a0f59d0db80994d0982ae04b7f9ec357bb8882ff38012d3a17893192845869e1640083aad20a2 SHA512 00c78abac0c08beb72ec11bcddd74165db773a0fa9b4eee10290a27c4c143f1593254e058898dc12aee1afc6bad5bb2849451e6018129aa32e808eee1b97420c
-DIST numdifftools-0.9.13.zip 225820 BLAKE2B a8d358dc95fa3a99f09e41db62e5bc4206ea1ce114ec3a138601157617acb194a7637b5ce5fe374d4e53327e63b66971f4bac246e4c08d80395a77d69a30faaa SHA512 e16fe167cbcc7995e5f7b1784822b94bc82261821ebf35f8b9f774ef1fd601ef13a23a72670f28b54b5f288b509a9ffccbde09033bdec6a88e8a4ef78ed74b25
-DIST numdifftools-0.9.14.zip 350053 BLAKE2B 482d4b4ec853ca8675961179f7c6b9d9f4160c833690784a43081ef4368eafd58b9e4922f9f57f81e99a85673d9f585008b8b0dc645586dfb30281274009084d SHA512 a69c878a31fa96c0b3f65c486ac75359242b6215868f24f3554be9ca104ac477bc786df7046bc830120d8fabbc475de40ab3db77c21c0d54756ccec1829fd8ae
 DIST numdifftools-0.9.17.zip 363422 BLAKE2B fa57ef2b9cb6dcaa669f14720f3fd1ed105f48b16549acd7bb6d7633b17cd45355022c9949a6099c3cbddc6b1a74b0f669344c4dd5e6f5ad56cc640549f4650c SHA512 acef3865861c76f0850b6f1c5ca5633f695603a7458c79569bbe887404c8490845d935693c57ea18468fe3cb7f864fe5481285f731dc933b6c0b521e3b888328
diff --git a/dev-python/Numdifftools/Numdifftools-0.9.12.ebuild b/dev-python/Numdifftools/Numdifftools-0.9.12.ebuild
deleted file mode 100644 (file)
index bc725d2..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN=numdifftools
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Solves automatic numerical differentiation problems in one or more variables"
-HOMEPAGE="https://pypi.org/project/Numdifftools/ https://github.com/pbrod/numdifftools"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.zip"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
-       >=dev-python/algopy-0.4[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       >=dev-python/numpy-1.9.0[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       >=sci-libs/scipy-0.8[${PYTHON_USEDEP}]
-       "
-DEPEND="
-       >=dev-python/setuptools-0.9[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-       )"
-
-# Seems to be broken
-# https://github.com/pbrod/numdifftools/issues/11
-# https://github.com/pbrod/numdifftools/issues/12
-RESTRICT="test"
-
-S="${WORKDIR}"/${MY_P}
-
-python_prepare_all() {
-       sed \
-               -e "/numpydoc/d" \
-               -i requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       esetup.py test
-}
diff --git a/dev-python/Numdifftools/Numdifftools-0.9.13.ebuild b/dev-python/Numdifftools/Numdifftools-0.9.13.ebuild
deleted file mode 100644 (file)
index c0e0928..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN=numdifftools
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Solves automatic numerical differentiation problems in one or more variables"
-HOMEPAGE="https://pypi.org/project/Numdifftools/ https://github.com/pbrod/numdifftools"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.zip"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/algopy-0.4[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       >=dev-python/numpy-1.9.0[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       >=sci-libs/scipy-0.8[${PYTHON_USEDEP}]
-       "
-DEPEND="
-       >=dev-python/setuptools-0.9[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/pyscaffold[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}"/${MY_P}
-
-python_prepare_all() {
-       sed \
-               -e "/numpydoc/d" \
-               -e "/wheel/d" \
-               -i requirements.txt *egg*/requires.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       esetup.py test
-}
diff --git a/dev-python/Numdifftools/Numdifftools-0.9.14.ebuild b/dev-python/Numdifftools/Numdifftools-0.9.14.ebuild
deleted file mode 100644 (file)
index 64d2482..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN=numdifftools
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Solves automatic numerical differentiation problems in one or more variables"
-HOMEPAGE="https://pypi.org/project/Numdifftools/ https://github.com/pbrod/numdifftools"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.zip"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/algopy-0.4[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       >=dev-python/numpy-1.9.0[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       >=sci-libs/scipy-0.8[${PYTHON_USEDEP}]
-       "
-DEPEND="
-       >=dev-python/setuptools-0.9[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]
-       dev-python/pyscaffold[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-runner[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}"/${MY_P}
-
-python_prepare_all() {
-       # pulls coverage test
-       sed \
-               -e '/tests_require/d' \
-               -i setup.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       esetup.py test
-}