dev-python/docker-py: add version 1.9.0_rc2
authorAlex Brandt <alunduil@gentoo.org>
Sat, 16 Jul 2016 14:07:26 +0000 (09:07 -0500)
committerAlex Brandt <alunduil@gentoo.org>
Sat, 16 Jul 2016 14:12:29 +0000 (09:12 -0500)
Package-Manager: portage-2.3.0

dev-python/docker-py/Manifest
dev-python/docker-py/docker-py-1.9.0_rc2.ebuild [new file with mode: 0644]

index 7844c34b3d60ae004f0aee427d7f3b19e152c3f8..3b6d6a535022af7c734b283fdccd234ae2de2475 100644 (file)
@@ -2,3 +2,4 @@ DIST docker-py-1.2.2.tar.gz 69685 SHA256 85284a5b1a965e01a5d0a91f9f639ad5069143a
 DIST docker-py-1.8.0.tar.gz 102575 SHA256 6a2feb4dad94ff01401af1bd1455ca20505af4bb5439f1c80114020461c4cf58 SHA512 60ac793d3061aec4fe46c694a00207560138895c7c6299a6734f2413601648da5130db00dbf33f41c3a91a717d825b9d1ce76413df2ae433b30a61eead373b39 WHIRLPOOL e5e204e7754fe5b038ef218718063892661636bd4ce51a160479725562865076ae2a3c99c38721b7c4f184ba45390f4c5a28582b83311af81da67867cf05a643
 DIST docker-py-1.8.0_rc2.tar.gz 100120 SHA256 5176c543343a582f2f7a461560a7c759d002b2dceb7552f542d7d1e0fce3cb05 SHA512 f7924015bc267acb095a9f21d151afd56d787a5d26dcc8c285d81c4e5af8a1027c7f166b8178e3e821a3b2fe541b51121c825ab59591b97bea8eb8a3fe3d7a0f WHIRLPOOL 451fea912c3cdd6bcaf7e29431719c39d7fea9bb03b7b94fbecf493bc28713d97e1438ee6ce8c0fb6977739061c25a87b29e5924e087e8613fe1f115b8000809
 DIST docker-py-1.8.1.tar.gz 101171 SHA256 82dc8db8088576ec5c42c203f7c46a88a26963e137ee0dafbf7e33882d75eb47 SHA512 c05412a43a774cc402e8f1bbb6c389c17e7fc335db4cfbe2d8a7001d7389f74fe51b3a2120bbbde640d93c5788283651b992389e3a09852eecb10e87e13466a0 WHIRLPOOL 47bdb88c07385d98cf5922ee420f85a93a84c62cc807acd9b0093ce55c386a4bd9f3cca1603e00259d32b0c3f0617282c49f23e4f67ead803a1ea5850ddeafc3
+DIST docker-py-1.9.0_rc2.tar.gz 105689 SHA256 30770466eef8fe5db3ac75ede506bb412de8a59600954089b385b4d134d54051 SHA512 8c4993aea477ae640660d10f80ca0a9b5f40f1d7a446cc67d392b824c78272ee32d42004952a70a3a55a105f313c06338266b206f4193cab736fa84c3c9b4d8c WHIRLPOOL bf1329f20095d519756a68bc3bd2a95d6d476366e1cfdc38eb38a6ad4a25da11964a20d039fb32af69dd4bd76b578b43b3b6b468767ba2fc8305b088019ae17c
diff --git a/dev-python/docker-py/docker-py-1.9.0_rc2.ebuild b/dev-python/docker-py/docker-py-1.9.0_rc2.ebuild
new file mode 100644 (file)
index 0000000..2c9b498
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV=${PV//_/-}
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( >=dev-python/mkdocs-0.14.0[${PYTHON_USEDEP}] )
+       test? (
+               ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+               ~dev-python/pytest-2.7.2[${PYTHON_USEDEP}]
+               ~dev-python/pytest-cov-2.1.0[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_3' 'python3_4' )
+       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+
+python_compile_all() {
+       if use doc; then
+               mkdocs build -d 'mkdocs_site' || die "docs failed to build"
+       fi
+}
+
+python_test() {
+       py.test tests/unit/ | die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( mkdocs_site/. )
+
+       distutils-r1_python_install_all
+}