gui-apps/mako: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 13 Feb 2020 22:47:16 +0000 (16:47 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 13 Feb 2020 22:54:19 +0000 (16:54 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
gui-apps/mako/Manifest
gui-apps/mako/mako-1.3.ebuild [deleted file]
gui-apps/mako/mako-1.4.ebuild [deleted file]

index 3b0ccd8656603c7a4d9c153f2f4fc0785c5b4a43..63735b841177bd27734f3135db371a8c7059153b 100644 (file)
@@ -1,3 +1 @@
-DIST mako-1.3.tar.gz 46482 BLAKE2B ea7699f713aded0476f3a9b88d90fa8d3bbd4e64e888caa68a98208625cdd15f1261c389dcb8ab43c6fbc77e1ebc0840b378443a1b350ff16adc59b98b9be0a8 SHA512 efada6ac413d80949669df3124ab9979537dcedd535132de57338b484ff2c81da8da59503a14dc2e9bbb266101659dd1d399d66456d383fdd1853d9137587259
 DIST mako-1.4.1.tar.gz 49442 BLAKE2B aa242d905d33dcfd2e30317a65d3826ba43ad344e93d1f41ed8b28f75310f724ed0eb5ae163f97a441ae07a4bb3465aa01f974cd95f97ba981a907fb761ad3d4 SHA512 25b0f59645c1815d8bdba42cedd6f56163ff663cd801a534c4c725c99e9a8cc28aef1d2c899d30cca06f0c6ddfa4a8e6efa01e5e98091347bcfc80d596f16d43
-DIST mako-1.4.tar.gz 48418 BLAKE2B ebd3c2f6fb7d51df826cab469c3e12477ec4503e3dfdfb4e9700393c0d994f6d7fcce6f3471d5faf90c5eb4bfa766941b97b0c8a8a556b5639ad5f3612df3082 SHA512 6059103e3a0c0cca5b0f717fbd7522f9a13f3dd3d65fe674e65cc175122a3372041bee2050d253ccb47a2adaa1dfa3180a19276bcdcb20c1e00813d75e1b3683
diff --git a/gui-apps/mako/mako-1.3.ebuild b/gui-apps/mako/mako-1.3.ebuild
deleted file mode 100644 (file)
index 3b9ffdd..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
-HOMEPAGE="https://github.com/emersion/mako"
-
-if [[ ${PV} == 9999 ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
-else
-       SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="amd64 arm64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+icons"
-
-DEPEND="
-       dev-libs/wayland
-       x11-libs/pango
-       x11-libs/cairo
-       || (
-               sys-apps/systemd
-               sys-auth/elogind
-       )
-       sys-apps/dbus[user-session]
-       icons? (
-               x11-libs/gtk+:3
-               x11-libs/gdk-pixbuf
-       )
-"
-RDEPEND="
-       ${DEPEND}
-"
-BDEPEND="
-       virtual/pkgconfig
-       app-text/scdoc
-"
-
-src_configure() {
-       local emesonargs=(
-               -Dicons=$(usex icons enabled disabled)
-               "-Dwerror=false"
-       )
-       meson_src_configure
-}
diff --git a/gui-apps/mako/mako-1.4.ebuild b/gui-apps/mako/mako-1.4.ebuild
deleted file mode 100644 (file)
index 3b9ffdd..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
-HOMEPAGE="https://github.com/emersion/mako"
-
-if [[ ${PV} == 9999 ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
-else
-       SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="amd64 arm64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+icons"
-
-DEPEND="
-       dev-libs/wayland
-       x11-libs/pango
-       x11-libs/cairo
-       || (
-               sys-apps/systemd
-               sys-auth/elogind
-       )
-       sys-apps/dbus[user-session]
-       icons? (
-               x11-libs/gtk+:3
-               x11-libs/gdk-pixbuf
-       )
-"
-RDEPEND="
-       ${DEPEND}
-"
-BDEPEND="
-       virtual/pkgconfig
-       app-text/scdoc
-"
-
-src_configure() {
-       local emesonargs=(
-               -Dicons=$(usex icons enabled disabled)
-               "-Dwerror=false"
-       )
-       meson_src_configure
-}