dev-python/pytest-xdist: fix broken tests
authorVirgil Dupras <vdupras@gentoo.org>
Mon, 4 Feb 2019 19:55:04 +0000 (14:55 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Mon, 4 Feb 2019 19:55:04 +0000 (14:55 -0500)
Closes: https://bugs.gentoo.org/673106
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/pytest-xdist/pytest-xdist-1.23.2.ebuild

index b3fefb375b77d9dfebcb3a6fe020f5ce0b0a2c92..f7e24b5867ef9db72a856e59c1abf8cb279458b2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -22,10 +22,13 @@ RDEPEND="
        dev-python/pytest-forked[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
 "
+
+# See #673106 about the pytest-xdist blocker.
 DEPEND="${RDEPEND}
        !!dev-python/pytest-capturelog
        dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       test? ( !!<dev-python/pytest-xdist-1.22 )
 "
 
 python_test() {