net-analyzer/nmap: Version 7.70.
authorJeroen Roovers <jer@gentoo.org>
Wed, 21 Mar 2018 20:58:22 +0000 (21:58 +0100)
committerJeroen Roovers <jer@gentoo.org>
Wed, 21 Mar 2018 20:58:22 +0000 (21:58 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

net-analyzer/nmap/Manifest
net-analyzer/nmap/nmap-7.70.ebuild [new file with mode: 0644]

index ac6015a86c819811e08d3ddf5975b01e40dca167..3d383771ece7eb084ad0b1fb44e5e98a85d52bc7 100644 (file)
@@ -1,4 +1,5 @@
 DIST nmap-7.40.tar.bz2 9043221 BLAKE2B ddbc2f9d8b96aa2ddd53bb250acb5b0829dd79caf04d599ed2257f89cc1e419a9dbf94101a5b1d5ad6815e1a94974b3c02ad81354897ba3bb032a5e3d616468d SHA512 98e37bf1c29789ea19ee4542d719ed6970c8bcc1bf92af4948a52a75273c2403329149f6b5df6368c23840d1bb3f47af9e5ce543f7a36596a33896609574f02d
 DIST nmap-7.50.tar.bz2 9309616 BLAKE2B 79f257f4c19762729ddfe7bb950263253d98b0902d22f0bf87ff64b7400c5e0c8e8c1a6b5a8c75e3f835dedbf7087808b1bd8444126655138382ea2db1ccb748 SHA512 b74c5711f03bae363164cdb7e62923ab938c81c7bbcd080eaa2d1acc89f09eb0a7e0f5deb9628b81057c7a35ecd487a2d09dfe3b58b0db6c84cf0b39f526e5f2
 DIST nmap-7.60.tar.bz2 10394925 BLAKE2B bb3a392292adeebe60dc9716ee61ee09a2f86703a1370ffd6a6c63969a75733660046279d122b1b529a3ea25083bde9334d5e13496ad6a9bd9d6562031b8ae09 SHA512 74ba8f6de026ade9ee6bb2252bee18a57210f8207977df7f1c04556629dcdc1e6127f33febc8a52ef88a1dac876116d590564dee4f1c23798c3ac37529991aa4
+DIST nmap-7.70.tar.bz2 10467371 BLAKE2B 53d751773851e45fcfa7604f8b325297f429f525bafdef91e7f693b9a9876ddb23e978c50821776b64764adb5bf36e759042cac3254bdbf36bff7048dfb6f58d SHA512 084c148b022ff6550e269d976d0077f7932a10e2ef218236fe13aa3a70b4eb6506df03329868fc68cb3ce78e4360b200f5a7a491d3145028fed679ef1c9ecae5
 DIST nmap-logo-64.png 3289 BLAKE2B 9563f57d126e6fa38dc777391c2887112836b4f5b521311bde64d5c5a04c45a3f420abba0750f776658015c0018b2afeb381c691bc8784e4f39abc78b9c2d2c7 SHA512 fb102d12aaeebc8a97543ecd653a3606e86996ad679bc26d6e6e274ad05ec3e9f92521289d1a24153c521b699e8c0cfa65d8856bb49af53ee4837268bbc6b5d3
diff --git a/net-analyzer/nmap/nmap-7.70.ebuild b/net-analyzer/nmap/nmap-7.70.ebuild
new file mode 100644 (file)
index 0000000..59a746d
--- /dev/null
@@ -0,0 +1,194 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,xml"
+inherit autotools flag-o-matic python-single-r1 toolchain-funcs
+
+MY_P=${P/_beta/BETA}
+
+DESCRIPTION="A utility for network discovery and security auditing"
+HOMEPAGE="https://nmap.org/"
+SRC_URI="
+       https://nmap.org/dist/${MY_P}.tar.bz2
+       https://dev.gentoo.org/~jer/nmap-logo-64.png
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="
+       ipv6 libressl libssh2 ncat ndiff nls nmap-update nping +nse ssl system-lua
+       zenmap
+"
+NMAP_LINGUAS=( de fr hi hr it ja pl pt_BR ru zh )
+
+REQUIRED_USE="
+       system-lua? ( nse )
+       ndiff? ( ${PYTHON_REQUIRED_USE} )
+       zenmap? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+       dev-libs/liblinear:=
+       dev-libs/libpcre
+       net-libs/libpcap
+       libssh2? ( net-libs/libssh2[zlib] )
+       ndiff? ( ${PYTHON_DEPS} )
+       nls? ( virtual/libintl )
+       nmap-update? (
+               dev-libs/apr
+               dev-vcs/subversion
+       )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:= )
+       )
+       system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
+       zenmap? (
+               dev-python/pygtk:2[${PYTHON_USEDEP}]
+               ${PYTHON_DEPS}
+       )
+"
+DEPEND="
+       ${RDEPEND}
+       nls? ( sys-devel/gettext )
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-5.10_beta1-string.patch
+       "${FILESDIR}"/${PN}-5.21-python.patch
+       "${FILESDIR}"/${PN}-6.46-uninstaller.patch
+       "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
+       "${FILESDIR}"/${PN}-7.25-no-FORTIFY_SOURCE.patch
+       "${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
+       "${FILESDIR}"/${PN}-7.25-libpcre.patch
+       "${FILESDIR}"/${PN}-7.31-libnl.patch
+)
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       if use ndiff || use zenmap; then
+               python-single-r1_pkg_setup
+       fi
+}
+
+src_unpack() {
+       # prevent unpacking the logo
+       unpack ${MY_P}.tar.bz2
+}
+
+src_prepare() {
+       rm -r libpcap/ || die
+
+       cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
+
+       default
+
+       local lingua
+       if use nls; then
+               for lingua in ${NMAP_LINGUAS[@]}; do
+                       if ! has ${lingua} ${LINGUAS-${lingua}}; then
+                               rm -r zenmap/share/zenmap/locale/${lingua} || die
+                               rm zenmap/share/zenmap/locale/${lingua}.po || die
+                       fi
+               done
+       else
+               # configure/make ignores --disable-nls
+               for lingua in ${NMAP_LINGUAS[@]}; do
+                       rm -r zenmap/share/zenmap/locale/${lingua} || die
+                       rm zenmap/share/zenmap/locale/${lingua}.po || die
+               done
+       fi
+
+       sed -i \
+               -e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
+               Makefile.in || die
+
+       sed -i \
+               -e '/rm -f $@/d' \
+               $(find . -name Makefile.in) \
+               || die
+
+       # Fix desktop files wrt bug #432714
+       sed -i \
+               -e 's|^Categories=.*|Categories=Network;System;Security;|g' \
+               zenmap/install_scripts/unix/zenmap-root.desktop \
+               zenmap/install_scripts/unix/zenmap.desktop || die
+
+       sed -i \
+               -e '/AC_CONFIG_SUBDIRS(libz)/d' \
+               -e '/AC_CONFIG_SUBDIRS(libssh2)/d' \
+               configure.ac
+
+       cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
+
+       eautoreconf
+
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # we need the original for a Darwin-specific fix, bug #604432
+               mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
+       fi
+}
+
+src_configure() {
+       # The bundled libdnet is incompatible with the version available in the
+       # tree, so we cannot use the system library here.
+       econf \
+               $(use_enable ipv6) \
+               $(use_enable nls) \
+               $(use_with libssh2) \
+               $(use_with ncat) \
+               $(use_with ndiff) \
+               $(use_with nmap-update) \
+               $(use_with nping) \
+               $(use_with ssl openssl) \
+               $(use_with zenmap) \
+               $(usex libssh2 --with-zlib) \
+               $(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
+               --cache-file="${S}"/config.cache \
+               --with-libdnet=included \
+               --with-pcre=/usr
+       #       Commented out because configure does weird things
+       #       --with-liblinear=/usr \
+}
+
+src_compile() {
+       local directory
+       for directory in . libnetutil nsock/src \
+               $(usex ncat ncat '') \
+               $(usex nmap-update nmap-update '') \
+               $(usex nping nping '')
+       do
+               emake -C "${directory}" makefile.dep
+       done
+
+       emake \
+               AR=$(tc-getAR) \
+               RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+       LC_ALL=C emake -j1 \
+               DESTDIR="${D}" \
+               STRIP=: \
+               nmapdatadir="${EPREFIX}"/usr/share/nmap \
+               install
+       if use nmap-update;then
+               LC_ALL=C emake -j1 \
+                       -C nmap-update \
+                       DESTDIR="${D}" \
+                       STRIP=: \
+                       nmapdatadir="${EPREFIX}"/usr/share/nmap \
+                       install
+       fi
+
+       dodoc CHANGELOG HACKING docs/README docs/*.txt
+
+       if use zenmap; then
+               doicon "${DISTDIR}/nmap-logo-64.png"
+               python_optimize
+       fi
+}