lxqt-base/lxqt-qtplugin: add version 0.15.0
authorJimi Huotari <chiitoo@gentoo.org>
Mon, 27 Apr 2020 17:48:40 +0000 (20:48 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:27 +0000 (01:28 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
lxqt-base/lxqt-qtplugin/Manifest
lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0.ebuild [new file with mode: 0644]

index d9acca89a5717747a36f91f31546ad9085ae9b89..074ae9fefd62e3846c1e84092032245a3e514fb4 100644 (file)
@@ -1 +1,2 @@
 DIST lxqt-qtplugin-0.14.0.tar.xz 22336 BLAKE2B 8155722880cff279aa26676ed425a011b2259ba94bf92122c59643a0ac6dd89b2841bcbeeac26ac24ef1e351dcdbcabf339c4a2bcee2dac30f2f9298434f7294 SHA512 33188bc03ee48a9b6e3cc5823cdcb5c96dba0cda65da511fe603d952c5de24e292cb02208cf357b04718df90f98d53bf48eaf6793d70d043214e429f57ccf53c
+DIST lxqt-qtplugin-0.15.0.tar.xz 22776 BLAKE2B 642270939ddaf9884da611d800c6ccae518a2c259e2da37c3e0025e24a6a11bae1d21cc9d4141821dfcf2e6e4c9b383e800dc68ff9d5f9b39f2e27e121d158c7 SHA512 9a73b9d38e1c2e2e030b551f92d53afef69fedee8f0ff4c7147680c0037a3eacb98f5514e09f16762c03cdaded7e5f760a89d66461bab4d7e8877ebaba28160e
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.15.0.ebuild
new file mode 100644 (file)
index 0000000..6e0fc33
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+       >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+       dev-libs/libdbusmenu-qt:=[qt5(+)]
+       >=dev-libs/libqtxdg-3.3.1
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5=
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       =x11-libs/libfm-qt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"