New version with support for ipod write, cd ripping, more plugins, and lots of bug...
authorJoe McCann <joem@gentoo.org>
Mon, 19 Jun 2006 01:32:17 +0000 (01:32 +0000)
committerJoe McCann <joem@gentoo.org>
Mon, 19 Jun 2006 01:32:17 +0000 (01:32 +0000)
Package-Manager: portage-2.1_rc3-r5

media-sound/rhythmbox/ChangeLog
media-sound/rhythmbox/files/digest-rhythmbox-0.9.5 [new file with mode: 0644]
media-sound/rhythmbox/rhythmbox-0.9.4.1.ebuild
media-sound/rhythmbox/rhythmbox-0.9.5.ebuild [new file with mode: 0644]

index 97cdfc82087bbdf4f8b22d225b9f1fbf8cda0379..16d934e413fe5e4a15bd2f1c8b1cb1767b872d7d 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/rhythmbox
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.75 2006/06/07 21:04:31 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.76 2006/06/19 01:32:16 joem Exp $
+
+*rhythmbox-0.9.5 (19 Jun 2006)
+
+  19 Jun 2006; Joe McCann <joem@gentoo.org> +rhythmbox-0.9.5.ebuild:
+  New version with support for ipod write, cd ripping, more plugins, and lots
+  of bug fixes
 
   07 Jun 2006; Joe McCann <joem@gentoo.org> rhythmbox-0.9.4.1.ebuild:
   remove restrict since it shouldn't be there in the first place
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.9.5 b/media-sound/rhythmbox/files/digest-rhythmbox-0.9.5
new file mode 100644 (file)
index 0000000..e970a3f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ff55e1db114321b7bdd6e21df1879367 rhythmbox-0.9.5.tar.bz2 2429543
+RMD160 b51fd8800d00fd8a8ad16e1ab511cb40630fd4f1 rhythmbox-0.9.5.tar.bz2 2429543
+SHA256 63607430da44df029b9b82d43cea887b0217c2e058432be65e5a3b5fa8baba43 rhythmbox-0.9.5.tar.bz2 2429543
index b24c0336aded2dac3610d99806f8829b7f1ae24d..0bdc442be9140804f702d66b3d48846f5f6971d1 100644 (file)
@@ -1,17 +1,14 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.4.1.ebuild,v 1.3 2006/06/07 21:04:31 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.4.1.ebuild,v 1.4 2006/06/19 01:32:17 joem Exp $
 
 inherit gnome2 eutils
 
-MY_P="${P%%_*}"
-
 DESCRIPTION="Music management and playback software for GNOME"
 HOMEPAGE="http://www.rhythmbox.org/"
-SRC_URI="http://ftp.gnome.org/pub/gnome/sources/rhythmbox/0.9/${MY_P}.tar.bz2"
 LICENSE="GPL-2"
 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="vorbis flac aac mad ipod avahi howl daap dbus libnotify musicbrainz
+IUSE="hal vorbis flac aac mad ipod avahi howl daap dbus libnotify musicbrainz
 tagwriting python"
 #I want tagwriting to be on by default in the future. It is just a local flag
 #now because it is still considered experimental by upstream and doesn't work
@@ -28,8 +25,8 @@ RDEPEND=">=x11-libs/gtk+-2.5.4
        >=media-video/totem-1.1.5
        musicbrainz? ( >=media-libs/musicbrainz-2.1 )
        >=net-libs/libsoup-2.2
-       ipod? ( >=media-libs/libgpod-0.2.0
-                       >=sys-apps/hal-0.5 )
+       hal? ( ipod? ( >=media-libs/libgpod-0.2.0
+                       >=sys-apps/hal-0.5 ) )
        avahi? ( >=net-dns/avahi-0.6 )
        !avahi? ( howl? ( >=net-misc/howl-0.9.8 ) )
        dbus? ( >=sys-apps/dbus-0.35 )
diff --git a/media-sound/rhythmbox/rhythmbox-0.9.5.ebuild b/media-sound/rhythmbox/rhythmbox-0.9.5.ebuild
new file mode 100644 (file)
index 0000000..135d00f
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.5.ebuild,v 1.1 2006/06/19 01:32:17 joem Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="vorbis flac aac mad ipod avahi hal howl daap dbus libnotify lirc musicbrainz
+tagwriting python"
+#I want tagwriting to be on by default in the future. It is just a local flag
+#now because it is still considered experimental by upstream and doesn't work
+#well with all formats
+
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.5.4
+       >=gnome-base/libgnomeui-2
+       >=gnome-base/libglade-2
+       >=gnome-base/gnome-vfs-2.7.4
+       >=gnome-base/libbonobo-2
+       >=gnome-extra/nautilus-cd-burner-2.9.0
+       >=media-video/totem-1.1.5
+       >=x11-libs/libsexy-0.1.5
+       musicbrainz? ( >=media-libs/musicbrainz-2.1 )
+       >=net-libs/libsoup-2.2
+       hal? ( ipod? ( >=media-libs/libgpod-0.2.0 )
+                       >=sys-apps/hal-0.5 )
+       avahi? ( >=net-dns/avahi-0.6 )
+       !avahi? ( howl? ( >=net-misc/howl-0.9.8 ) )
+       dbus? ( >=sys-apps/dbus-0.35 )
+       >=media-libs/gst-plugins-base-0.10
+       >=media-plugins/gst-plugins-gnomevfs-0.10
+       vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10
+                               >=media-plugins/gst-plugins-ogg-0.10 )
+       mad? ( >=media-plugins/gst-plugins-mad-0.10 )
+       flac? ( >=media-plugins/gst-plugins-flac-0.10 )
+       aac? ( >=media-plugins/gst-plugins-faad-0.10 )
+       libnotify? ( >=x11-libs/libnotify-0.3.2 )
+       python? ( >=dev-lang/python-2.4.2
+                               >=dev-python/pygtk-2.6 )"
+
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig
+       >=dev-util/intltool-0.29
+       app-text/scrollkeeper"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+
+       if ! use avahi && ! use howl; then
+               if use daap ; then
+               ewarn "Daap support requires either howl or avahi"
+               ewarn "to be installed. Please remerge with either"
+               ewarn "USE=avahi or USE=howl"
+               fi
+       fi
+       if use howl || use avahi ; then
+               G2CONF="${G2CONF} $(use_enable daap)"
+       fi
+
+       if use howl ; then
+               G2CONF="${G2CONF} --with-mdns=howl"
+       fi
+
+       if use avahi ; then
+               G2CONF="${G2CONF} --with-mdns=avahi"
+       fi
+
+       G2CONF="${G2CONF} \
+       $(use_enable tagwriting tag-writing) \
+       $(use_with ipod) \
+       $(use_enable ipod ipod-writing) \
+       $(use_enable musicbrainz) \
+       $(use_with dbus) \
+       $(use_enable python) \
+       $(use_enable libnotify) \
+       $(use_enable lirc) \
+       --with-playback=gstreamer-0-10 \
+       --enable-mmkeys \
+       --enable-audioscrobbler \
+       --enable-track-transfer \
+       --with-metadata-helper \
+       --disable-schemas-install"
+
+DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \
+         MAINTAINERS NEWS README README.iPod THANKS TODO"
+
+export GST_INSPECT=/bin/true
+USE_DESTDIR=1
+}