dev-embedded/platformio: Version bump
authorAlexey Shvetsov <alexxy@gentoo.org>
Fri, 17 Apr 2020 18:48:05 +0000 (21:48 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Fri, 17 Apr 2020 18:48:29 +0000 (21:48 +0300)
Closes: https://bugs.gentoo.org/715102
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
dev-embedded/platformio/Manifest
dev-embedded/platformio/platformio-4.3.1.ebuild [new file with mode: 0644]

index 3f393f7cbe166464179c5ebfa6937c820db01713..4b217cc3f9e047e866662c8ec0c931cac719f4e7 100644 (file)
@@ -1 +1,2 @@
 DIST platformio-4.1.0.tar.gz 157907 BLAKE2B e90d2b155121cd2be0b0d77a7a196e7fe03580083444056d06a86a343166c920cd1ac6252a0003acee4de5d3933fead939b8be8d67233e93c05537511344e27b SHA512 e4d6c29ebb8fb1b2b556affbc1a50ec84d12e878bb7e6cfb253861eb5429236d8226d1a29f1a3812c0aa2c5b4895f0354184a9cb28c300db2e2e5a2ededb82fe
+DIST platformio-4.3.1.tar.gz 169099 BLAKE2B 0a700869ab18d6c837a42fb408f676314760402141de561c318134d72084e33ef1fcea5b1c15c72b7a3131b2d4ab30cb333acf1b634165ba98ffd571640d00ba SHA512 bde939c7511733c7ed2c2139d3edb87dfa0e7179df96e9591155eef3179de0581c98c9544870824b35c1b3282df734f27640c6a4536e2b54e3fc9ba8e68adbb4
diff --git a/dev-embedded/platformio/platformio-4.3.1.ebuild b/dev-embedded/platformio/platformio-4.3.1.ebuild
new file mode 100644 (file)
index 0000000..e7bf816
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+       $(python_gen_cond_dep '
+               dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+       ')"
+RDEPEND="${DEPEND}
+       $(python_gen_cond_dep '
+               <dev-python/bottle-0.13[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/click-5[${PYTHON_MULTI_USEDEP}]
+               <dev-python/click-8[${PYTHON_MULTI_USEDEP}]
+               dev-python/colorama[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pyserial-3[${PYTHON_MULTI_USEDEP}]
+               <dev-python/pyserial-4[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/requests-2.4[${PYTHON_MULTI_USEDEP}]
+               <dev-python/requests-3[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/semantic_version-2.8.1[${PYTHON_MULTI_USEDEP}]
+               <dev-python/semantic_version-3[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/tabulate-0.8.3[${PYTHON_MULTI_USEDEP}]
+               <dev-python/tabulate-1[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pyelftools-0.25[${PYTHON_MULTI_USEDEP}]
+               <dev-python/pyelftools-1[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/marshmallow-2.20.5[${PYTHON_MULTI_USEDEP}]
+       ')"