x11-misc/rodent: Version bump to 5.3.16.3
authorChristoph Mende <angelos@gentoo.org>
Wed, 7 Oct 2015 17:49:43 +0000 (19:49 +0200)
committerChristoph Mende <angelos@gentoo.org>
Wed, 7 Oct 2015 17:49:59 +0000 (19:49 +0200)
Package-Manager: portage-2.2.22

x11-misc/rodent/Manifest
x11-misc/rodent/rodent-5.3.16.3.ebuild [new file with mode: 0644]

index 4d7cce9ea12133f86bd20e9ad5e23962ffbb1638..1c1603cce5577b53d09e0c0340203e16c4c9f772 100644 (file)
@@ -1 +1,2 @@
 DIST rodent-4.9.2.tar.gz 12061909 SHA256 d1e892ed22ad5eac65d915b0ac81d1c01b72699667429e7bc8847cc8c5ddc001 SHA512 776975bfff4e9e7b51e4f4b6f2d3e78c2fdeb949ed144dce66faa32b5a20f085201050500f26eb4af74ec63a354bb71ab39b8dd5eb9f95bffe289bb71bdd33a6 WHIRLPOOL 698facf1ff82b1c1a668437d7f0af253084e259f69459e00206ee4630809549187be89cc576534713376a2ab848a35b77c00881e2c5021cbeccc4e9e1fd3b40a
+DIST rodent-5.3.16.3.tar.bz2 10873231 SHA256 456ffaa4ef3b60af1a94dad0a35f1e3986235d81f00b257a3204074a2275f3d6 SHA512 83c85501d3fe49e84abe9bb61a23ca4ec86fb22abb2e9a01228b3180d114380ff085ee58f51b9ac47173214ab8323e0bde7cfca6fb9b7907d4b1551ad48326f5 WHIRLPOOL 2e8707d48b879209e225c8101f2919bb5cb327794da5d872ae5fa422bf2af39c2a828f0b81d359b9e7e06c18a5d8ff77d4249980293f62ea9833711c308360e5
diff --git a/x11-misc/rodent/rodent-5.3.16.3.ebuild b/x11-misc/rodent/rodent-5.3.16.3.ebuild
new file mode 100644 (file)
index 0000000..02849b5
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools
+
+DESCRIPTION="A fast, small and powerful file manager and graphical shell"
+HOMEPAGE="http://xffm.org/"
+SRC_URI="mirror://sourceforge/xffm/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/librfm-5.3.16.3"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       virtual/pkgconfig"
+
+pkg_setup() {
+       DOCS=( AUTHORS ChangeLog TODO )
+}
+
+src_prepare() {
+       pushd apps/rodent-pkg >/dev/null
+       sed -i -e "/^install-data-hook/d" \
+               -e "/rm -f/d" Build/Makefile.am || die
+       eautoreconf
+       popd >/dev/null
+}