Move clean-up code to pkg_postinst. Remove old versions. Bug # 153915. Thanks...
authorTom William Payne <twp@gentoo.org>
Tue, 7 Nov 2006 10:12:09 +0000 (10:12 +0000)
committerTom William Payne <twp@gentoo.org>
Tue, 7 Nov 2006 10:12:09 +0000 (10:12 +0000)
Package-Manager: portage-2.1.2_rc1-r4

dev-util/scons/ChangeLog
dev-util/scons/files/digest-scons-0.96.92-r2 [new file with mode: 0644]
dev-util/scons/scons-0.96.92-r2.ebuild [new file with mode: 0644]

index ea2cff5367b34b1fbc345b638e9b4b10d4745382..41574e56803d7da429e0e2423470f9500b29e1e2 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-util/scons
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.36 2006/11/03 14:03:33 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.37 2006/11/07 10:12:09 twp Exp $
+
+*scons-0.96.92-r2 (07 Nov 2006)
+
+  07 Nov 2006; <twp@gentoo.org> -scons-0.96.92.ebuild,
+  -scons-0.96.92-r1.ebuild, +scons-0.96.92-r2.ebuild:
+  Move clean-up code to pkg_postinst. Remove old versions. Bug # 153915.
+  Thanks jakub.
 
 *scons-0.96.92-r1 (03 Nov 2006)
 
diff --git a/dev-util/scons/files/digest-scons-0.96.92-r2 b/dev-util/scons/files/digest-scons-0.96.92-r2
new file mode 100644 (file)
index 0000000..11845d4
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 0b6b388cdd640b7f297f37a678c65d5c scons-0.96.92.tar.gz 372708
+RMD160 75aa04717da98eccabc42180f6eab9ee4b8bd904 scons-0.96.92.tar.gz 372708
+SHA256 c2ab6143174c0d3d2d6f2e5ae6bc77dd3a4843aba5e41d1265f54cdc2c17ebeb scons-0.96.92.tar.gz 372708
diff --git a/dev-util/scons/scons-0.96.92-r2.ebuild b/dev-util/scons/scons-0.96.92-r2.ebuild
new file mode 100644 (file)
index 0000000..35649c5
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.96.92-r2.ebuild,v 1.1 2006/11/07 10:12:09 twp Exp $
+
+NEED_PYTHON="1.5.2"
+
+inherit python distutils multilib
+
+DESCRIPTION="Extensible Python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.scons.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DOCS="RELEASE.txt CHANGES.txt LICENSE.txt"
+
+src_install () {
+       distutils_src_install
+       doman scons.1 sconsign.1
+}
+
+pkg_postinst() {
+       python_mod_optimize ${ROOT}/usr/$(get_libdir)/${P}
+       # clean up stale junk left there by old faulty ebuilds
+       # see Bug 118022 and Bug 132448
+       if has_version "<dev-util/scons-0.96.92-r1" ; then
+               einfo "Cleaning up stale orphaned py[co] files..."
+               [[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
+                   && rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
+               einfo "Done."
+       fi
+}
+
+pkg_postrm() {
+       python_mod_cleanup ${ROOT}/usr/$(get_libdir)/${P}
+}