dev-python/patsy: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:32:47 +0000 (12:32 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:36:39 +0000 (12:36 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/patsy/Manifest
dev-python/patsy/patsy-0.4.1.ebuild [deleted file]

index a19308dff17bec8c9e2d527487884d7e72263dab..f7b04d950b1467beae505280c623d2925e211b95 100644 (file)
@@ -1,2 +1 @@
-DIST patsy-0.4.1.zip 425390 BLAKE2B b8d5696abcf35fcd5e49a7d3efdfb201976efdbe7e845f136dd0cdbfb0972d8372e54b8f4141139cff9ad4df3525c67a10a3c71bc1471991a810e834e0dd0ad9 SHA512 24cf2e6f9a33e6dd795a839eb2b2ac9e0d45cd9c3d5250de17722914ac29436d0518388d0696b75d73236eda3c7819dc4fa24d6d9bc37d5ae035dde2af4510c3
 DIST patsy-0.5.1.tar.gz 397623 BLAKE2B b8861e8c8e223db5df616c378d5b1ce475a1b337d049723c1a4b01432d9e1569c4b6537dc467fbc1ba83dfc7cd999ad188008e387c446f2133f872393c9eb960 SHA512 aeb56411e68713ec75c0b5344890939f721c460d3c7643b9fd57d7c928421d21408b0f2963348edf27a025842989dbae6fd5cfccd3f9d9497d60a1dffe8d7bdc
diff --git a/dev-python/patsy/patsy-0.4.1.ebuild b/dev-python/patsy/patsy-0.4.1.ebuild
deleted file mode 100644 (file)
index 9223674..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module to describe statistical models and design matrices"
-HOMEPAGE="https://patsy.readthedocs.org/en/latest/index.html"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       "
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/ipython[${PYTHON_USEDEP}]
-               dev-python/matplotlib[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/pandas[${PYTHON_USEDEP}]
-               )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       cd "${BUILD_DIR}" || die
-       nosetests -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && HTML_DOCS=( doc/_build/html/. )
-       distutils-r1_python_install_all
-}