games-emulation/mupen64plus-rsp-hle: Bump to 2.5.9
authorMichał Górny <mgorny@gentoo.org>
Sun, 15 Sep 2019 08:54:28 +0000 (10:54 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 15 Sep 2019 09:51:15 +0000 (11:51 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
games-emulation/mupen64plus-rsp-hle/Manifest
games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.9.ebuild [new file with mode: 0644]

index e9d855d3812fe7491747d639013784df402ab849..977842322c9ad2b0985932c4e2de11b29f568a09 100644 (file)
@@ -1 +1,2 @@
+DIST mupen64plus-rsp-hle-src-2.5.9.tar.gz 53889 BLAKE2B e66996ffbce1d4b2b40f1520f0806692652dbf7baa55a73f632f2dafe75f93093e0575bb1c7e63cc1cd8770c1cc0e6d59db9021fcb0fa2e34d707511dd3a40b0 SHA512 562f3a9d9eff01f11c13aca657fb6471f365fbfbe079ea5e1e6f0ad49b27ba04779bc86233bcacd20c95c79f7fa265f053b3fa4c2b12828c6a8992762c4b6963
 DIST mupen64plus-rsp-hle-src-2.5.tar.gz 46998 BLAKE2B 3bb5ee627fa4c367e7dd1ef0ac0a1eae1267cf82ac66a35f4dcd972703b9cba832224cab1be20c75e9f61af2afae0c8eb7dd6ba806a47c57eef6e6c5da9e8a5a SHA512 564d96050890cc61df05163f99a0be8198e870f0d4071e87828bf58b283b2be8ca7de20ed03482ea8c45725bdd6f6baea618c068cced407892cf2add6ef373c6
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.9.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.5.9.ebuild
new file mode 100644 (file)
index 0000000..4d18794
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-src-${PV}
+inherit toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, HLE RSP plugin"
+HOMEPAGE="https://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-${PV}:0="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       default
+
+       # avoid implicitly appending CPU flags
+       sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+       MAKEARGS=(
+               # Note: please keep this in sync in all of mupen64plus-* packages
+
+               -C projects/unix
+
+               # this basically means: GNU userspace
+               UNAME=Linux
+
+               # verbose output
+               V=1
+
+               CROSS_COMPILE="${CHOST}-"
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+               PKG_CONFIG="$(tc-getPKG_CONFIG)"
+               # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+               # so we can leave OPTFLAGS empty
+               OPTFLAGS=
+
+               # paths, some of them are used at compile time
+               PREFIX=/usr
+               LIBDIR=/usr/$(get_libdir)
+
+               # disable unwanted magic
+               LDCONFIG=:
+               INSTALL_STRIP_FLAG=
+       )
+
+       use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+       use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+       emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       dodoc RELEASE
+}