sys-apps/gawk: Removed old.
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 19 Jun 2019 08:30:59 +0000 (10:30 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 19 Jun 2019 08:31:16 +0000 (10:31 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/gawk/Manifest
sys-apps/gawk/gawk-4.1.4.ebuild [deleted file]

index dd6872593406b60e5deb683b3e0c3ae9f42d4afb..04104bc29ee5b22e54031b4072f22a288fd51683 100644 (file)
@@ -1,4 +1,3 @@
-DIST gawk-4.1.4.tar.xz 2367832 BLAKE2B 67004e2867e4c4f43aac7142a52c83642d8bb3b0a5451293418bc15e575a8ed1d97c0a975e084bf46ffd1c27dc70e48de492cd2e007773622ef14886b9269ee1 SHA512 6a0e9cf086544212f54b54261dcd517b611aaf495ef99c4b7740d07e363bb00c5632f3d7fd5e12a954d5aa9793764162a57453e0e18884b29c6c54b5f444c097
 DIST gawk-4.2.1.tar.xz 2985412 BLAKE2B ea0635904ae8af8943d545b21affbfad64de5a688a615e22e1af2634583d0002094c0668c3260837184f965452ccf84141fff705bbf42d55b6d55c7516c24d8b SHA512 0e3006a795dc3ac91359a7d2590c0cccbfd39b18a1d491617d68505c55a2800355b1439050681b4fcacf65fb0d533151a046babe0fd774503037bab363ef2ae4
 DIST gawk-5.0.0.tar.xz 3000432 BLAKE2B d7885442c615e2b7986d6cb617db3ac376a5e572ab2aca3c6b2bd0f43feca4374f310bbf2e2a875b617df97cfebf98cb983d169468d51db39058b83eb9771afa SHA512 9eb663bbcad53165b7ddb7d72cfb8377252b68004733a9eb8c191b2ddddaff857e48ba811280311384243eb67574fbe7ac9edf4e507f9a82d67b4b2adff8ef6e
 DIST gawk-5.0.1.tar.xz 3136004 BLAKE2B 1dd8a9bca2488f2d3c946406b01fcbdce0487922ece49fe2121c39d6d10bcfcb6a056edbbf88ba6c22772ef88a250fc8ffcba33ead399c0d7c8f5d19d0e896d3 SHA512 ff9842a91035f843482d93eac8a35cddf2ce16acaa43a0112c1efff08802aebf705ee70d47eff74a190dca7be330c31f7204ad27cb63bdee65333f9b9c984212
diff --git a/sys-apps/gawk/gawk-4.1.4.ebuild b/sys-apps/gawk/gawk-4.1.4.ebuild
deleted file mode 100644 (file)
index af2a3ec..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="GNU awk pattern-matching language"
-HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
-SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mpfr nls readline"
-
-RDEPEND="mpfr? ( dev-libs/mpfr:0= )
-       readline? ( sys-libs/readline:0= )"
-DEPEND="${RDEPEND}
-       nls? ( sys-devel/gettext )"
-
-src_prepare() {
-       # use symlinks rather than hardlinks, and disable version links
-       sed -i \
-               -e '/^LN =/s:=.*:= $(LN_S):' \
-               -e '/install-exec-hook:/s|$|\nfoo:|' \
-               Makefile.in doc/Makefile.in || die
-       sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in #413327
-       # fix standards conflict on Solaris
-       if [[ ${CHOST} == *-solaris* ]] ; then
-               sed -i \
-                       -e '/\<_XOPEN_SOURCE\>/s/$/600/' \
-                       extension/inplace.c || die
-       fi
-}
-
-src_configure() {
-       export ac_cv_libsigsegv=no
-       econf \
-               --libexec='$(libdir)/misc' \
-               $(use_with mpfr) \
-               $(use_enable nls) \
-               $(use_with readline)
-}
-
-src_install() {
-       rm -rf README_d # automatic dodocs barfs
-       default
-
-       # Install headers
-       insinto /usr/include/awk
-       doins *.h || die
-       rm "${ED}"/usr/include/awk/config.h || die
-}
-
-pkg_postinst() {
-       # symlink creation here as the links do not belong to gawk, but to any awk
-       if has_version app-admin/eselect \
-                       && has_version app-eselect/eselect-awk ; then
-               eselect awk update ifunset
-       else
-               local l
-               for l in "${EROOT}"usr/share/man/man1/gawk.1* "${EROOT}"usr/bin/gawk; do
-                       [[ -e ${l} && ! -e ${l/gawk/awk} ]] && ln -s "${l##*/}" "${l/gawk/awk}"
-               done
-               [[ ! -e ${EROOT}bin/awk ]] && ln -s "../usr/bin/gawk" "${EROOT}bin/awk"
-       fi
-}
-
-pkg_postrm() {
-       if has_version app-admin/eselect \
-                       && has_version app-eselect/eselect-awk ; then
-               eselect awk update ifunset
-       fi
-}